AmpliFi HD Firmware v3.4.1

  • Sounds crazy. Moved to Ubiquiti a month ago given its status.

    Sad to say, this is Netgear like!

  • @Matt-Harrop Hello, Meshpoints automatically switch to opposite band (till next reboot) when selected band has some connectivity problems. If you are certain that signal strength is good enough for 5 GHz and do not ever want to connect over 2.4 GHz then go into WebUI and uncheck the new "Enable automatic backbone band switching" option. This is useful for preventing switching from manually set 2.4 GHz to 5 GHz. But might help you as well to force 5 GHz in case when 2.4 GHz is crowded. Just keep in mind that any interference in the air will make your MP offline.

    Are you using 3rd party router with same SSID name as AmpliFi?

  • HI. Thanks, i didn't know about the WebUI option to stop backbone switching.

    Yes the 3rd party router is same SSID just because i think some devices like sonos want to be on the same ssid and it's easy for mobile devices when to connect to when outside house (it's actually a (Draytek) master router in a garage near the house that dishes out the IPs and manages the WAN, the Amplifi is in the main house on bridge mode, the setup works great.).

    I just thought it strange that 24 hours after upgrading I had this weird behaviour where the mesh points started flashing and wouldn't connect to the HD and clearly it refused connection from these other devices also which jumped onto the different router, but there was nothing on the HD screen to suggest anything wasn't working. Will see if it happens again...

  • I tried a "preemptive" morning router reboot. But ended up with a stalled mesh point 90 min later.

  • Is a rollback from 3.4.1 to 3.3.0 somehow possible?

  • I rolled back to 3.3.0 and then did a factory reset but am still having frequent disconnects, mostly on my two MacBook Pros. One running Win10 and the other macOS 10.15. My other devices seem mostly unaffected.

    It was rock solid prior to me updating last week.

    I’m puzzled why downgrading didn’t restore that stability.

  • @kokernutz How do you actually do that as the WebUI only offers a rollback to 3.4.0 to me.

  • @UI-Karlis Got another slow down in the middle of a Zoom call. This is just not practical.

    • What is the expectation of the timetable for another release?
    • Is there a way to roll back to 3.1.2? I think that one worked better for me than the ones that followed.

  • @op2003 it was offering a rollback to 3.3.0 for me as of yesterday. I won't try up/downgrading again in case they yanked 3.3.0 from rollback options.

  • @kokernutz 3.3 had the same issues, just not as badly. 3.1.2 had it just a little.
    It's been a long time since I just "set and forgot" the AmpliFi same as my Ubiquiti.

    I used to run months without touching the network. This current state is insane. I am patient, have submitted many reports, never heard back on any underlying causes, while the firmware problems got worse. I am no longer recommending this system to my friends, who ask me as the local expert.

  • This post is deleted!

  • This whole situation literally boggles my mind. The 3.3.0 update was a disaster - right in the middle of a global situation where millions of people are working from home and are generally relying on their internet connections more than ever one would think that a little care and attention would be taken try and make sure that stable updates can be provided. Then it took months to come with an update to 3.3.0 and what happens? It gets even worse with 3.4. I threw my three Amplifi devices away having had enough after 3.3 - I don't need to spend time in my life tinkering with something that should just work. Seems like this was a good decision.

  • @Mark-Seall
    To be fair this is not everyone’s experience. My HD is running on 3.30 for 2 months and 28 days without restarting and the network is pretty stable

  • I'm also a month into using the Amplifi HDs coming from a Netgear Nighthawk. First thing I did after starting it up was to update the fw, which was 3.3.0 at that time.

    Think I've had one issue since then (hope I don't jinx it).

    Were there a lot of issues with 3.3.0?

  • @Timofey-K You are right. The challenge in such equipment is complexity. There are a lot of potential configurations out there. Some solutions are robust enough to handle that, some solutions require you to be lucky enough to have a safe configuration. The sheer number of responses on Amplifi update threads and the nature of some of the problems lead me to believe that while most people will probably be fine, there are too many situations where it just won't work for people.

  • @UI-Karlis I have sent a note to support. What is the process to get the v3.1.2 FW to revert. This is really impacting my work-at-home. The stalls are unpredictable and happen in the middle of Zoom meetings. Preemptive reboots of the mesh points do not help!

    I am the CTO of my company and cannot keep my home network running. This is very embarrassing!!!!!!

    I have noticed several requests in other forums for v3.1.2. Could you just provide a download link? Not sure there is a way to update with a downloaded file via web interface.

    Pls respond, there has been a bit of a radio silence while we struggle with this.

  • @Harald-Striepe said in AmpliFi HD Firmware v3.4.1:


    I think creating a repository of all the previous firmware versions for users to be able to download and install as they see fit is a very sensible and reasonable request and I can see no reason as to why AmpliFi cannot provide this for its customers.

  • @Ali-Hadi Ubiquiti has it for their EdgeMax and other firmware.

  • Like previous versions, version 3.4.1 works fine for me, using 10 HDs in bridge mode connected via ethernet. Those who have problems and use the root HD in router mode might consider to buy or reactivate a decent router and switch to bridge mode for the HD wifi mesh system. The router functionalities of the HD are anyway rather limited. I use a pfsense router appliance, but simpler routers will be sufficient.

  • @Otto-Wilhelm I already do that but it is not really a solution for other people's (and this ROUTER'S) problem, is it?

Log in to reply