AmpliFi HD Firmware v3.4.1

  • @James-Morgan Hello,If you are on 3.4.0 then better update to 3.4.1. But do it soon after manually restarting router while system is still stable. The more time will pass since router boot, the less memory it will have to successfully complete update operation.

  • Still on 3.1.2 and will stay here until a bug free update is found. This is absolutely rubish. How can there be so many problems with your updates? I’m honestly thinking of going with another mesh router to unlock full capabilities.

  • @kwitzke I only have an HD with no mesh points. Once I was able to get remote access back I was offered the update In the GUI as normal. I did have to reboot the HD after the update to stabilize it but afterwards all seems ok.

  • I'm not 3.4.0rc2 and while it's not great wondering if I should risk upgrading to 3.4.1?

  • @Chris-Herman have you tested a factory reset with your device just incase, seems to help exorcise the possession out of the LCD on my kit, I get random phantom touch on the screen.

  • @Nico-Christodoulakis the hardware is extremely limited especially in the ram department so I'm not surprised, as so as I have the chance I'm jumping to the alien units due to superior hardware.

  • @estesbubba I wonder if that same issue occurs on the alien units?

  • @Chris-Herman said in AmpliFi HD Firmware v3.4.1:

    now as of updating to the public v3.4.1 my router runs for about 24hrs and then crashes

    Hi, could you please email support info to AmpliFi support and ask to forward it to Karlis (me)? Thanks!

  • @Peter-McCloughan said in AmpliFi HD Firmware v3.4.1:

    Back to 3.4.0 since that at least worked. Hopeful that the stability issue gets resolved quickly

    Please try updating again and do not use 3.4.0. Possibly update failed because system run out of memory. It is fixed in 3.4.1.

  • Hi @UI-Karlis,

    Running on v3.4.1 since two days and it works fine and stability is there, at least for me.

    The problem with iOS devices has vanished (asking for password). Although I do have less performance on my Apple devices comparing to Windows and Android devices.

    On my Macbook 12 I got ca: 60% performance on Wifi comparing to my Windows 10 Laptop. Both ca: 5m from the router and both connected to same SSID on 5Ghz. Speed on Windows ca: 220 Mbps and on Macbook 130 Mbps. Upload is fine on both, ca: 90 Mbps.

    All devices updated with latest os, drivers and fw.

    I have moved my iOS devices to a dedicated 2,4Ghz SSID shared with my IoT/Smarthome/Camera devices. Speed around 30-40 Mbps when I test.

    All tests done with Speedtest.

    Kind regards,


  • @Mikael-Johansson Yeah, it maybe works for you but not for everyone else.

    And yes we all have tried your suggestion settings but the main problem is in the firmware and not in diffrient settings!

    The support team must fix it once and forever because 3.4.0 and 3.4.1 is the same since people reporting same issue's, that wifi become slow and after a restart then it works and then again becomes slow.


  • @Eric35 I totally agree with you was 3.3.0 was bad for Apple devices and 3.4.x even worse.

    Just realized that 3.4.0rc2 randomly paused a couple of my 2.4Ghz IoT devices. Kept reseting the IoT devices and tried to re-add to WiFi and they kept failing. Just noticed they were paused in the Amplifi app, un-paused, and guess what? They work again!

    I decided to bite the bullet and upgraded from 3.4.0alpha2 to 3.4.1 and it upgraded just fine. All Apple devices have speeds of ~78/10 on my 80/10 connected and I'll see how long it lasts.

  • I have been running 3.4.1 for 2 days now. So far, the network is stable, which is most important to me since my wife and I are both working from home. My system is comprised of four RAMPs connected via ethernet backhaul. I can't comment on Wi-Fi speeds as I use ethernet connections as much as possible. Devices that do use Wi-Fi and all IoT devices were fine over the past 48 hours as well.

  • 3 hours after installing 3.4.1 and rebooting again after the install here is where my home MacBook Pro is at already on my solid 80/10Mbps internet connection. Other Apple devices are also slowing down but not this bad yet.


  • @Chris-Herman Same here. Disconnects multiple times per day. No internet even though main router from the cable company is perfectly fine. I downgraded, then tried the upgrade again. We’ll see.

  • Great up to now until my TV stalled. Reboot.

  • All fine here on 3.4.1 as far as I can tell, none of the issues that I saw on 3.4.0

    Good speeds on my iPad Pro and various other iPhones and iPads in the household.

    My MacBook has only 802.11N (late 2012 retina) but I get full speed on that too.

    My work laptop Dell Latitude - no issues

    All boxes checked on the web ui except A-MSDU for wireless clients (I didn’t see much improvement there)

    The only issue I’ve had for a while now is the Sony TV doesn’t connect properly, only when I setup an additional SSID on the AP I want it to connect to, but I think this is more an issue with the crappy NIC or Android TV. - Also this already occurred on previous firmwares as well.

  • @UI-Karlis updated yesterday, 24hrs later and spotted my three mesh points are all flashing, the android App suggests I'm not connected to the amplifi WiFi (although I am on my android phone) so can't access any settings or see what's going on.
    Rebooting the HD and now works and the meshs reconnected (but same problem as before one has connected to base unit rather than in a chain despite reporting a v weak signal so it should connect in chain... Only solution is to go into mesh setting and force it back to 5ghz for it to do this. Why does it keep going back to 2.4ghz and trying to connect to HD base unit despite v v weak signal??) but strange I've never had this problem before and suddenly now 24hrs after firmware upgrade.

    Also noticed today many devices sitting just within reach (but a good 20m or so away) of a non amplifi router had jumped onto that instead of the much much stronger amplifi signal they usually connect to in the same building. So takes a lot of time to go round the house rebooting these also to force them back onto amplifi network.

  • Firmware is getting more complicated, maybe a beta switch to turn on local ssh so we can look at logs, services and loads to see that is going on?

    Some people are 100% good, others are 100% bad, that's nuts!

Log in to reply