AmpliFi HD Firmware v3.4.1

  • @Otto-Wilhelm I am running in bridge mode, but still experience the mesh point slow downs. With all HD routers you have a different use case.

  • I completely agree that the situation with these deficiencies for some use cases in not satisfactory at all, and I cannot understand why this cannot be fixed, apparently. I think, that my HD wifi mesh system could be faster and have a more stable connection speed, which appears to substantially vary sometimes but is nevertheless always fast enough from a practical point of view. I decided to stick to the HDs and to be pleased that a good (good from a practical point of view, not from a theoretical point of view) connection speed is guaranteed at all times at all places of my site, until an upgrade to a wifi 6 system might become appropriate one day (I think not in the near future).

  • Ok. Now I am seriously mad.
    I got instructions on how to downgrade the Router HD (trivial) and was asked to put the Mesh Points in recovery mode to downgrade.

    • The instructions for setting the Mesh Point to recovery were very foggy and not fully correct.
    • I then discovered I could downgrade my other two mesh points via the web interface. That worked smoothly.
    • I was not told that the Router would lose its SSID. Didn't to take too long to discover that and fix.

    But the Mesh Point with the recovery reset will no longer connect to the network. And the chat with UI-Brett has been abandoned. No more response!
    I have tried a second recovery and downgrade, looking for it with the app in recovery etc. etc.

    It does not connect, it does not show in the app for configuration standalone. It just sits there blinking.

    And Amplifi has apparently gone home after giving me bad instructions. The thing is long out of warranty so I cannot return it.

    This really, really sucks!

    Does anybody have any ideas on how to reconnect this mesh point. Resetting does not make it show up.

    I should note this is one of the two Mesh Points that came with the Router - so permanently bonded. A third was an odd on, but this one is not it.

  • Hi @Harald-Striepe - just to confirm, you have one HD kit + one standalone MeshPoint HD correct?

    All 4 units have now been successfully downgraded to v3.1.2?

    Now one MeshPoint from the kit will not connect to the HD router it is bonded to?

    And if you factory reset both of the kit MeshPoints first, and then factory reset the HD router, they do not come back online and re-establish their pairing as they would with a brand new installation (i.e. same room, bluetooth enabled on app device, etc.)?

    I would take any standalone MeshPoint HD's offline, factory reset them, and leave them unplugged until the Kit is back up and running

  • @Derek-Saville I have not factory reset the router or other mesh points and am reluctant to do so. AmpliFi reliability is horrible these days and we use this for work.

  • Hi @Harald-Striepe - sorry, I was confused by the statement...

    But the Mesh Point with the recovery reset will no longer connect to the network.

    I thought that a 'recovery reset' had the same effect as a 'factory reset' and once you do that to a Kit MeshPoint, you need to perform the reset to both kit MeshPoints first, then reset the Kit HD router, and only after all 3 have been reset in the correct order will the Kit MeshPoints reestablish their pairing

    But I have not personally done a recovery mode reset on a kit before

  • @Harald-Striepe out of despair I did. Everything is reset. All groups etc. lost. After much hullabaloo and time I got the two Mesh Point that were connecting to reconnect (they need to be real close to the router.)
    And ... I am back where I was. The third Mesh Point (part of the original router group) still does not connect.

  • @Derek-Saville A recovery reset is 30+ seconds and longer than a factory reset.

  • @Derek-Saville I had not much trouble with the two that had already been connecting. The troubled one is still not working.

  • @Harald-Striepe Did a full reset of all components to no avail. Only two out of three mesh points are working.

  • @Harald-Striepe out of despair I did. Everything is reset. All groups etc. lost. After much hullabaloo and time I got the two Mesh Point that were connecting to reconnect (they need to be real close to the router.)
    And ... I am back where I was. The third Mesh Point (part of the original router group) still does not connect.

  • Hi @Harald-Striepe - I don't mean to cause you any extra work or unnecessary trials - just trying to help think through what could be wrong

    The troubled one is a Kit MeshPoint, and if you put it back into recovery mode, you can access it directly via it's SSID and confirm it is on v3.1.2 the same as all other devices?

    Mismatched firmware is often a culprit

    Did you perform a normal 10 second factory reset after the recovery reset?

    But, every time time you do a 'reset' on a Kit, my understanding is that you have to make sure you do it all again in the correct order on all 3 devices, in the same room so they can properly generate and exchange keys, before they will mesh nicely again

    Serious pain, and I can't guarantee that will fix whatever is wrong with your one problematic MeshPoint

  • @Derek-Saville Tried all of this no no avail. At least I still have a working router and two mesh points. Never had these issues with the Apple Airport family.

  • This morning I made another attempt and was successful:

    • Line all mesh points on an outlet strip close to the router
    • Factory Reset Mesh Points - 10s pin prick to get beep
    • Factory Reset Router and reconfigured
      All Mesh Points connected one after another.

    I am now successfully reverted to 3.1.2!

    Thanks for everyone's advice. I will keep you posted on reliability.

  • I have been trying to roll back to v3.1.2 and did a factory reset on all devices but noticed that for some crazy reason that the mesh points have now a completely different MAC address to the one they had with the other firmware vesrion. I mean, why does hardware MAC change depending on firmware version and what is the point in that apart from creating problems?

  • Hi @Ali-Hadi - if you reverted to a pre-v3.3.0 release it goes back to the old code which had the different MAC addresses for the mesh points and WAN in bridge mode, etc.

    From v3.3.0 onward the MAC addresses will no longer change

  • Had another one of those random non connection issues after upgrading to 3.4 where there is no message or error on the HD router and all my mesh points go into 'search mode' and won't connect to the HD.

    Fortunately for me powering off and on the HD seems to fix it and the mesh points then reconnect but takes a good 5-10 minutes for everything to get back up and running
    As others said if this happened during a big conference call or when I'm not in the house to fix for others this would be a nightmare.
    Both times it's happened late ish into the evening.

    Never happened on previous firmwares, exactly the same setup I had before

    Looks like it's causing people headaches, there must be some fixes to make in the code to push out an update that could help fix these issues!

  • Since the upgrade to 3.4.0 and then, to a lesser extent, since 3.4.1 I’ve been having devices disconnecting. Most noticeably, Sonos speakers stopping playing and then being unreachable.

    I want to go back to the software immediately previous to 3.4.0. I’ve basically had no problems with Amplifi for a year until the disaster of 3.4.x. It’s awful.

    I’d suggest that Ubiquiti cut their losses and just revert everyone back to before 3.4.x and try again from a starting point where the products actually worked. No point digging further.

  • After reading these comments I decided to take the plunge and upgrade. I upgraded from 3.3.0 which I had experienced disconnects with. I rebooted and upgraded to 3.4.1 and after 72 hours I have had no issues. I would actually say the system is a lot more stable than 3.3.0. I will continue to monitor.

  • This post is deleted!

Log in to reply