AmpliFi HD Firmware v3.4.1


  • @Ade-Thompson Unifi HD Flex. Thry are nice.


  • @Mark-Seall Thanks Mark, Do you use them wired or in wireless uplink (mesh mode)?


  • @Ade-Thompson Wired...


  • @Derek-Saville Thanks for that info, especially what happened between the release of 3.1.2 and 3.3.0. In addition to COVID-19, completing regulatory requirements and introducing Alien there was a lot of pressure on what I assume is a small staff.

    My Opinion, based on what little info I have.
    I feel the Alien should have been delayed until the compliance issues were worked out since these same compliances were probably also being implemented in Alien. When the same compliance issues are going to affect multiple products one should be completed to make the work somewhat easier for the unreleased product I feel this explains some of the myriads of problems the Alien is having. The bottom line it appears that under the circumstances the staff was/is stretched too thin.

    I wonder if it was a marketing decision to go ahead and release Alien because of some preset release date? This too often overrides good project/product management when unforeseen issues arise that affect multiple products.


  • @caw35ubi I would definitely go for 3.1.2. I have 3 HDs connected via a wired backbone and it’s very stable. No forced restarts since this firmware was released.


  • @John-Meinen-0 Wholeheartedly agree. I am still using 3.1.2 and beginning to wonder when there will be a new stable update for the Amplifi HD! I usually wait a month before updating and I am so glad I did not go to any of the updates after 3.1.2.


  • Hi @James-Earl-Ford - a pretty large beta v3.4.2rc0 release just dropped recently with a lot of updates, so hopefully a stable update is close...
    https://community.amplifi.com/topic/3372/amplifi-hd-instant-and-hw-teleport-firmware-3-4-2rc0

    Changes from the previous version 3.4.1:

    • Fixed networking related crash with hundreds of clients
    • Fixed STP related crash
    • Fixed networking related memory leak
    • Security fixes (CVE-2020-12762)
    • Implemented faster mesh point recovery when IP subnet changes
    • Limited processes memory usage
    • Implemented better handling of Ethernet loops
    • Fixed UPnP daemon not to use link-local address
    • Fixed igmpproxy to work when LAN subnet changes
    • Sped up information retrieval from the switch
    • Allowed 6to4 IPv6 to be used for Teleport connections
    • Improved internal diagnostics
    • Several other stability fixes
    • Updated internal packages
    • WebUI enhancements

  • @Derek-Saville Thanks for the notice about the Beta update. I will again wait at least a month after it is released before deciding whether to install it. Between HD and Alien, I know developers and support are busy.


  • @James-Earl-Ford Fully agree and that's why I haven't upgraded the last two times and continue to be happy. I'm in no rush.


  • @Derek-Saville Security fixes (CVE-2020-12762) appears to be a json issue, not remotely exploitable, local only. Any more details on how it's an issue for Amplifi?


  • Security fixes (CVE-2020-12762)

    Hi @Matthew-Leeds - I do not have any direct first hand knowledge

    If you would accept speculation, I strongly believe AmpliFi also moved to UbiOS with a custom AmpliFi specific container (vs the Unifi OS container), and they did so on the HD series as well with v3.3.0

    This is evidenced by what are now being referred to as "Updated Internal Packages"

    It is supposed to be a more modular and portable system and the Security Fixes for CVE-2020-12762 could be related to that

    PS - or could it be related to the AmpliFi backend cloud which the routers communicate with a psuedo controller?


  • @Tigres I'm going to chime in since I've been on a few threads including this one related to 3.12 and beyond. I've had the eero pro for 3 weeks now since moving from the HD. I loved the HD until 3.12 which was good but not great. I still got dropped homekit devices and my apple airport connected to a NAS would keep dropping off after a few days requiring a reboot of the router or the airport. Since moving to the eero pro I've have 1 dropped homekit device. And it dropped it only once. I have not had to reboot my airport due to connection issues. It's been solid.

    The eero pro system has been set and forget.

    Although there are not as many settings to tinker with I'm not sending logs, rebooting the system or having pissed off family or Zoom customers to deal with. I feel this is a firmware issue. I hope support is listening because I chose NOT to buy into the "family" again. I run a home based business and to me the amount of money this HD system costs should have better service and systems in place for performance than this.

    I have 50 devices and I'm mostly apple based items. I'm finally doing other things again besides messing with my wifi - although I'm hanging on to my HD in case they get their sh&t together and then I may have a decent backup to my eero. Good luck everyone. I have felt your pain.


  • And the Oscar goes to...3.1.2! 🍾 🥂

    I'm in no hurry to upgrade, so I'll take a look at the release notes but, unless I find something compelling, I'll stay where I am.

    Thank you for taking the time to reply, @Derek-Saville @John-Meinen-0 @James-Earl-Ford


  • Would someone from support or other members of the forum be kind enough to send me the link to downoad v3.1.2 as this latest version has also stopped working for me with mesh points disconnecting and finally not being able even to access router's settings from the App or Web UI? Shame really as I was trying to give it a good run but finally gave in and unfortunately would not be able to role back to 3.1.2 without a direct install. Any help is much appreciated.


  • Have been on the 3.4.2rc0 beta. So far so good.


  • @Ali-Hadi all you have to do is contact support and they'll provide the info. You don't need to fight for it, and if you do that you'll have it in seconds.


  • @Derek-Saville @John-Meinen-0 @James-Earl-Ford

    Chaps,

    at the risk of heading off-topic, what chance that 3.1.2 solves an issue that sees my Amplifi slow down over the course of a few days, requiring a reboot to bring it back to ISP speed (this repeats and is fixed in the same way)?

    I see countless threads in this forum on the subject, but no solution (most threads descend into a debate about modem types, but I don't see what that has got to do with it having had no problems with mine over the years).

    I am rapidly coming to the conclusion that Amplifi HD is a dud and will likely return it.


  • @caw35ubi it’s definitely worth while trying based on the stability and performance I’m seeing. I literally never had a need to restart my HDs since 3.1.2 was released last year (?) ...


  • @caw35ubi said in AmpliFi HD Firmware v3.4.1:

    at the risk of heading off-topic, what chance that 3.1.2 solves an issue that sees my Amplifi slow down over the course of a few days

    I got 2 HD's using one as a RAMP in February and 3.1.2 was the current firmware then. It was solid and I could get my full 80/10mbps anywhere in my house through both the main HD and the RAMP. Once 3.3.0 was released problems started to happen especially with Apple devices and 3.4.1 is even worse.

    Support asked me 2 weeks go if I would be willing to try an alpha and I did. Because I'm WFH and can't risk having no internet I put the alpha on my RAMP and made it my main HD, and unplugged my 3.4.1 HD so I could use it if the alpha caused problems. The alpha that I'm on did not fix the Apple problems but showed that the problems aren't just with mesh points.

    Hopefully they'll get it fixed soon as I really like the devices and it was solid for months with no problems with 3.1.2.


  • I successfully downgraded my AmplifiHD and mesh points to 3.1.2 yesterday just to regain some sort of stability and I’ll watch the progress of the recently released 3.4.2 beta firmware to see if things improve before updating again. I really hope they manage to get the firmware right and address everyone’s issues as the hardware is spot on.


Log in to reply