3.4.1 firmware


  • How is everyone finding the new 3.4.1 firmware update? For me, it seems pretty good. I’ve now been running it for nearly 48hrs and it’s been pretty good. WiFi speed has improved although it can fluctuate a little but is consistently 75% or more of my line speed, sometimes up to 90% when testing from the same place in the same room as the router. Loads better than 3.3.0 although not quite as consistent on speed as 3.1.2


  • Hi @hunterp

    I have the same experince as you. Although my Apple devices (Macbook/iOS) are slower than my Windows/Android devices. But it seems to be a common problem.

    I have 250/100 Mbps connection and I got around 220-230 Mbps download for my Windows laptop.

    Except from speed, stability is the best improvement according to me.

    Br,

    ////Mike


  • I have been running 3.4.1 for 2 days now. So far, the network is stable, which is most important to me since my wife and I are both working from home. My system is comprised of four RAMPs connected via ethernet backhaul. I can't comment on Wi-Fi speeds as I use ethernet connections as much as possible. Devices that do use Wi-Fi and all IoT devices were fine over the past 48 hours as well.


  • @hunterp hi could you help me out a bit here. I wanted to know from your experience which version was the best for you. Was 3.1.2 better or 3.4.1. couse im considering rolling back to 3.1.2. Anyone else comments would help too. All i care about is more consistent stable wifi. 3.3.0 has been very inconsistent with speed drops.


  • @Abrar-Chowdhury In my experience 3.1.2 was a little faster than 3.4.1 using WiFi but only by a very small amount and it could have just been down to my environment variables at the time. I’m talking of a speed difference of around 5% at most. I’ve been running 3.4.1 on my router and mesh points now for 3 days 18hrs and it’s been rock solid. Seems to be a good stable release on the Amplifi Instant devices. Speed is meeting my expectations. I’d say go up to 3.4.1 so that you’ve got a good solid platform and can take advantage of the additional settings and features in the web UI. If you’re currently running 3.3.0, you’ll see a massive improvement as it was a very poor release


  • @hunterp hi, thanks for the reply. I actually went ahead and tested both for the past 2 days now. First day tried 3.4.1 and it was a lot better than 3.3.0 which has been very unstable. 2nd day i have tried 3.1.2 which has honestly been miles better. The speed consistency is about the same but the stability of the network has improved a ton. Even in games the latency has been better and rock solid compared to 3.4.1 and 3.3.0. i don't know why an older firmware would be soo much better than newer stable releases. I recommend anyone to try rolling back to 3.1.2 if you are not satisfied with the latest releases. The only thing i miss is the DNS adblock setting. Other than that its better.


  • Cannot test here as when I check for updates with the Web UI I am told that no updates are available.


  • @codfish yeah its not available everywhere right now. It depends on where you live. I didn't receive it either but u can contact the support team on the Live support option and they will guide you through a manual update. Its fairly easy if you want to.


  • I found my issue in the 3.3 firmware threads. But I have had this issue of 2-3 seconds internet drops for 2 months now. I have the Amplifi HD and I'm on firmware 3.4.1

    I tried many things thinking it was my provider/modem

    I thought I had it solved by changing the default DNS to another DNS. However it worked perfectly for one day and then back to normal. Really annoying with any online meetings where my sounds drops on either side. I think it worked perfectly for one day since the router got restarted.

    Any suggestions? How do I roll back to 3.1.2?


  • @Johan-van-Mierlo said in 3.4.1 firmware:

    Any suggestions? How do I roll back to 3.1.2?

    You can roll back to your previous firmware using the RollBack feature in the WebUI


  • @UI-AmpliFi I saw that but it rolls back to 3.3. Please correct me if I'm wrong but does 3.3 has the same problem?


  • @UI-AmpliFi I did roll back to 3.3 and problem is still there. Now the only thing is I can't roll back further. Just up again


  • Contact support and they'll provide the 3.1.2 firmware and instructions.


Log in to reply