Be able to pick WiFi channel on all units


  • I would like to be able to select a WiFi channel. Don't say "you can do that", because you cannot. The only thing you can do is select the channel used by the main router. Then the mesh points just go and pick a channel they consider the best.

    I checked using a WiFi scanner. My Amplifi system is using channel 1, 6 and 11. And there is nothing I can do about it.

    This is, if I may say so - and I may -, totally ridiculous. Totally. Completely. Entirely. Spectacularly. Ridiculous.


  • Yeah, it's totally ridiculous that this option is not available...


  • @Jarek-Kulik Channels 1,6 and 11 are the only channels that are recommended to be used for the 2.4Ghz range.

    I used the WiFi Explorer app to learn which 2.4Ghz channel my system was currently using and see if one of the other channels is used less. Once I determined that one of the other channels was used less, I changed to that channel.

    To make a change in the 2.4Ghz range do the following.
    Open the Amplifi app.
    Click Wireless.
    Scroll to the bottom and click Advanced.
    Under 2.4Ghz turn off Automatic.
    Click channel (1,6, or 11) you want to make the default for the 2.4Ghz range.

    If you want to change the channel used in the 5Ghz range use the same steps except doing so for the 5Ghz setting.


  • @James-Earl-Ford Nope. Read my post again. You can set the channel for the main unit, you cannot set the channels used by the mesh units. Whatever channel you select, the mesh units will go ahead and pick their own channels.

    This is not a bug, customer support told me, but the way the system is supposed to work.

    Why does this bother me?

    SONOS recommends you set the SONOSnet channel and your Wifi channels apart. Well, you can select a SONOS channel in the SONOS app, and all SONOS equipment will then use that channel. But you cannot select the AMPLIFI wifi channel the same way. As I said, whatever you set in the app, it ONLY applies to the main router. The mesh routers just do their thing. Crazy. Primitive. Stupid. Ridiculous. etc etc


  • @James-Earl-Ford only on the main unit - not on the mesh point 😞


  • @Wouter-van-Nispen-tot-Sevenaer
    Sorry I read your message based on the title and did not read the content close enough. I probably would have read it differently if the words "mesh units" had been in the title.


  • @James-Earl-Ford Fixed it. Only now the subject heading is all in caps. No idea why.


  • I also would like this added. For me, if I change the 5GHz band on the main router, the 5GHz band on both mesh point also change to match the router. But if I change the 2.4GHz band on the router, the mesh points stay on whatever random channel they were on. Not sure why one changes and the other does not. But I also can confirm that Amplifi told me through a support email that the system is designed to only change the channel on the main router and the mesh point get their own random channel when they boot.
    But for me, it is odd that one band will change and the other will not. Makes me think that maybe the option is already in the coding somewhere. Mine has been like this since I bought the unit, has not changed with any firmware updates or even a 30-30-30 reset.


  • An update to my request with this. I said that with my mesh points using the 5GHz band for its backbone connection, the 5GHz band on the mesh points matches that of the main router when changed. I tried switching the mesh points to the 2.4GHz band and sure enough, the 2.4GHz band on the mesh points match the main router as the channel is changed. So there has to be some programming in there already for the mesh points to match the main router for the back bone connection band, so hopefully it can be modified for both bands to match the main router.


Log in to reply