Brand new AmpliFi HD, meshpoints won't go online.


  • Just bought a brand new Amplifi HD and the mesh points will not come online. They're plugged in, and flashing blue lights, and right now they're about 10 feet away from the main unit but the app says they're offline.

    I've tried the firmware update, and the problem persists. What steps can I take here?


  • @Brad-Lacke Do you know if the reset buttons were triggered on either of the mesh points? If so, the primary router will need to be reset as well to allow them to communicate.


  • I don't believe that they've been triggered - I just took them out of the box and plugged them into various wall outlets.


  • @Brad-Lacke Everything in a kit will automatically pair, unless a factory reset has been triggered. If they have not come online, I would suggests factory resetting the router to start the initial pairing process over, this should bring the mesh points back online.


  • Thanks for your help. I ended up taking the kit back and got a different Amplifi box which worked right away.


Log in to reply