Amplifi Alien Primary DNS cannot be Internal (PiHole issues)


  • Re: pihole again
    Seeing others discussing this issue back in Early 2019 I thought I'd start a new topic.

    SHORT ANSWER: Primary DNS cannot be an internal DNS on Amplifi Alien running Firmware 3.4.0. You must put a failing DNS in Primary in order for the Alien to allow the PiHole to provide DNS to the network.

    To confirm, I had PiHole functioning on an AmplifiHD with no issues for multiple years. After upgrading to the Amplifi Alien, I thought I'd rebuild the PiHole with the latest Raspbian Buster, PiHole 5 and reconnect it as I had previously.

    I set the PiHole as the Primary DNS and enabled "Bypass DNS Cache".

    The Alien reports that the DNS fails in Diagnostics. The PiHole address is pushed out through DHCP properly and the system will fail to query the PiHole through nslookup. If there is a Secondary DNS it will ignore the PiHole and simply allow DNS to function through the Secondary DNS.

    Lots and lots of trial and error (I should have probably tried to wireshark it) I decided to set another internal DNS server up and see if I could forward it to the PiHole trying to trick the Amplifi. I setup a Synology DNS with Forwarding enabled and plugged it's IP into the Primary DNS and the PiHole into the Secondary DNS. When I refreshed the DHCP it provided both internal addresses to my computer but nslookup would fail the primary DNS and fall back to the Secondary DNS (i.e. the PiHole).

    It seems that Amplifi Alien will not allow an Internal DNS request when set in the Primary but you can trick it by putting the PiHole as Secondary DNS and simply put a local or non-responsive IP in the Primary DNS.

    Hope this helps someone else and if the Amplifi team sees this, I'd love to know why this is happening.


  • @advadmin so it works if you restart the amplifi. I don't know why, but my diagnostics report correctly if I restart the amplifi after setting up the pihole and making it primary DNS.


  • @Matt-Anger Thank you, will try this myself and confirm.


  • While this is quite old, I feel like I owe it to the community to update. Pi-Hole + Alien works great. Here's how.

    1. I have an Amplifi Alien, latest firmware.
    2. I disabled the DNS Ad-blocker from the web admin site for the Alien.
    3. I enabled the "Bypass DNS Cache" setting from the web admin site for the Alien.
    4. Installed Pi-Hole on my raspberry pi (AFTER establishing a static IP via the Amplifi iOS app).
    5. After getting the static IP, I established that static IP as my primary DNS server.
    6. REBOOT the Alien.
    7. PROFIT.

    It works.


  • Just to add what @Jordan-Sembower posted, just make sure that you check the DHCP server enabled and then click Save in Pi-hole's Settings.

    0_1618159130791_Screen Shot 2021-04-11 at 9.32.17 AM.png


Log in to reply