Sky Fibre DHCP Option 61 Issues


  • I’m struggling to get my AMPLIFI HD to connect to the internet using a DrayTek Vigor 130 modem. I’ve tried multiple different formats for the Client ID but with no success. Does anyone know the correct format (do we include the | or : between username and password etc) before converting to hexadecimal?


  • @Ashok2429

    I'm using this whch i found searching on Google.

    37633463613531323334353640736b7964736c7c6162636431323334

    It works fine.


  • I too am struggling,
    Using the same ID but no joy, have followed so many guides and tried all of them with no joy.


  • @Hobbsie

    Hey, I finally got mine working, give the below a go and see if it works. You don’t need the hexadecimal as the web app now has a converter.

    1. Put the Vigor 130 into bridge mode (does not come confirgured out of the box as such). To do this you need to plug the Vigor into an Ethernet port on your computer and follow these instructions https://www.draytek.co.uk/support/guides/kb-vigor-130-bridge

    2. Once this is done head to the AMPLIFI web app to configure the DHCP Client ID for the handshake. Put this address into your browser http:/amplifi.lan/ - Note this can't be done through the mobile app.

    Once in the web app enter a sky username/pwd in the correct text format (username@skydsl|password) and then select convert to hexadecimal in the AMPLIFI web app. Hit save and wait a couple of minutes and you should be online!


  • @Ashok2429 HI thanks i have tried that several times even using different layouts of the client ID still no joy.
    It just never connects to the internet 😞 factory reset everything multiple times.
    I have used a BT openreach modem and a draytek vigor 130
    Literally going to throw it all out the window 🙂 problem is the sky router is so bad im getting it in the neck from the kids lol.

    Not sure where i go from here i have left it conencting for hours but just never connects im not sure if its the draytek not passing over or the amplifi not playing ball but its such a simple set-up i cant believe i'm having these issues of it not connecting?


  • im wondering if it may be the username and password, from what i read it does not matter as long as the structure is correct.
    But i have tried several that were posted earlier on in this forum but to no joy.


  • @Hobbsie

    Could well be the issue I made up a new one rather than use another. My username was 9 digits long, combination of letters/numbers then the password 16 digits long with combination of letters/numbers.


  • @Ashok2429 thanks ill give it ago fingers crossed 🙂


  • No joy sadly.
    I have tried a ton load of different options for the username and password with no joy.
    I like to think I’m fairly knowledgable in this field as I use to Olin home automation and W use to install airport, Cisco, and other systems but all with Bt so I know I have the draytek in bridge mode as we use to use these daily.
    So I have absolute no idea why this is not working.

    The most annoying part is I cannot return the AmpliFi now as iv had it half a year or so.

    So stuck with an expensive mesh system that I can’t use a the worlds most useless sky router that can’t even handle 25 smart devices in the network!


  • OK so after a bit of digging i am on sky fibre ultrafast that requires a G.Fast modem!
    Apparently no manufacturer has yet released support for the G.fast modem.

    So this is why i could not connect just thought id put that here as it may help someone else unless i was being a plonker and its an obvious thing!


Log in to reply