Stand Alone Mesh Point Issue - Solved

  • Well, I purchased a Black Amplifi Router direct from Amplifi about a week ago. As the black doesn't come with Mesh Points, I purchased two from Micro Center. Micro Center questioned my purchase as every mesh point has been returned over the last month. I quickly found out why.

    I hooked up the router and things went pretty well. Immediately upon turning it on it asked to update the firmware which I went ahead and installed. Once I started pairing the Mesh Points it look like things were working ok, I received a check mark on the app that said it was paired but once the mesh point rebooted it just locked into a 3 light blinking routine. Numerous resets, tech support calls (reading from scripts) nothing worked.

    I then remembered the firmware update on the router. I tried to pair the mesh points as standalone with the Amplifi Router with but then received a password error. Said the password was incorrect but it was the correct wifi password.

    Finally, I had an idea. I created a wifi network with one of my old routers and connected the mesh point to the new non Aplifi wifi network. It connected immediately and I was able to update the firmware on each of the mesh points. I then reset the mesh points now with the new firmware and it connected to the Aplilfi network flawlessly.

    The Amplifi system is a great product, but having hardware not connect due to a firmware update is unacceptable. I now know what they have been returned so often.

    I'm guessing the firmware update was to add security for the recent Krack Attack venerability. It's just unacceptable to brick the mesh points due to a router update. Really makes the company look bad.

Log in to reply