Huawei modem - no IP address message


  • I purchased the amplifi HD and set it up last week. I’m with plusnet and it transpires I can’t put my plusnet router into bridge mode.

    I have since purchased the huawei openreach modem to replace the router with due to the above but I’ve just plugged the amplifi into it and it’s saying ‘no IP address’.

    Has anyone got a similar set up and can help? Thanks so much


  • @miklo27 you would need to set up your AmpliFi in PPPoE mode and then enter your Plusnet's username and password to connect.


  • Thanks so much for ur reply. So if I put the amplifi into the PPPoE mode does that essentially mean the amplifi is in something similar to bridge mode (and therefore l has limited functions)


  • @miklo27 no, it will still do all the routing as you do not have a router anymore with the openreach modem. You won't lose any of the AmpliFi's functionality.


  • Hi @miklo27 - if you require IGMP for multicast TV or any other features, please note that the AmpliFI IGMP Proxy previously was not working in PPPoE mode

    I am not sure if anything has changed in any recent firmware releases, but to my knowledge the situation has not changed


  • @Ali-Hadi thanks very much. I’ve tried changing to this mode and putting in the password but had no luck. I’ll try contacting their support to see what’s up as I’m not getting any where fast!


  • @Derek-Saville thanks very much. If I’m honest I’m not sure if I need that or not but it’s good to know as if I do ever get this working then if something doesn’t work I’ll assume it’s that!


  • @miklo27 Have you added @plusdsl.net to your plusnet username? This would for example be: miklo27@plusdsl.net


  • @Ali-Hadi Yeah I did and it still said it couldn’t find a connection. I even wiped it back to factory settings and started the set up again from scratch with the modem in case there was another lingering setting I wasn’t aware of but no luck on that front either. For now I’ve gone back to the original router and just have the 2 running next to each other. I know this will cause noise from the 2 routers trying to both do the same thing but it’s at least working for now until I can solve it. Thanks so much for ur help!


  • @miklo27 This is definitely a problem with your huawei openreach modem setup and not with the AmpliFi. I had the same setup with Plusnet but using Vigor130 modem with no issues whatsoever.


  • @Ali-Hadi I thought so, so that’s good to know about ur set up.

    All the right lights are illuminated on the modem so I know its physically working as such and therefore presumably not broken but something clearly isn’t right with it. I’ll do some more researching, and if not maybe I’ll have to give in and try another modem. Thanks again you’ve been a real help!


  • @miklo27 You may need to power cycle your equipment. AmpliFi has a unique boot order in which AmpliFi needs to be powered on first, then once it shows "Plug in cable" on the screen you power on the modem. With all the recent settings changes you have made, this might be all thats needed.


  • @UI-AmpliFi hi, thanks for the suggestion. I did try this actually as I reset the whole thing back to factory settings and start led the set up from scratch but that didn’t solve it. Thanks though, I appreciate all suggestions!!