Alien LCD Screen Showing Blank


  • @UI-AmpliFi I'm having this strange issues on my newest Alien where the LCD screen completely went blank. It has a white hue when you turn up the brightness that shows the screens on but there's absolutely nothing on the display.
    I tried restarting it but nothing happens. My older unit that's used as a mesh is working fine. This just started happening about 15 mins ago.


  • SOLVED: I had to Factory Reset... along with unplug it to get it working again.


  • @Tristan-Baptist Did this stay fixed for you? I appear to be having the same problem. Power cycling the Alien fixes it for a short while but eventually the problem returns.

    -dp


  • @pawpuh So far so good. It's done it one more time a few months ago but I haven't seen it happen again. Knocks on wood


  • @pawpuh Hi. We have seen this issue for very few customers.
    Please enroll in the Beta program and update your Alien to the latest Beta version.

    1. Go to http://amplifi.lan/settings.php
    2. Log into your router
    3. At the bottom of the settings you will see Receive Beta firmware updates

  • @UI-AmpliFi said in Alien LCD Screen Showing Blank:

    http://amplifi.lan/settings.php

    Hi @UI-AmpliFi - done. I'm now on 3.5.0beta2 59-0-g907e814e70. Front LCD is displaying again on my root Alien without having to power cycle (satellite Alien never exhibited the problem). Will let it cook for a while to see if this sticks. I'm interested if rolling back to 3.4.3 would reproduce the problem again or if the repair would hold if not many other people are seeing this (i.e., root cause is a bad 3.4.3 upgrade from the factory shipped release).

    -dp


  • @pawpuh Thank you for your feedback. We will notify the developer team about this issue and fix it in the next public release.


  • Hi @UI-AmpliFi - after a couple of days on the beta without any drama and no recurrence of the blank LCD, I rolled back to 3.4.3 and the problem reproduced fairly soon afterwards. Just rolled forward again to 3.5.0beta2 59-0-g907e814e70 and will track with the beta until it goes GA.


  • @UI-AmpliFi - spoke too soon. Woke up to the root Alien having come out of night mode and a blank LCD, with the satellite having normal LCD behavior.


  • @pawpuh You must have a faulty device here...


  • @Ali-Hadi - I was suspecting that at first until the suggestion to try the beta software originally produced LCD stability. After my last message, I powered cycled the box so it came up cold with the beta version and it's been good for a few hours. Maybe I'm overly optimistic but perhaps 3.4.3 was doing something to the LCD ASIC that survives warm reboots and upgrades but not cold reboots.

    Anyway, I'm trying everything I can before assuming it is bad hardware. I don't care for the warranty policy of having to pay shipping and then potentially get a refurb unit in return.


  • Hi @pawpuh - have you tried the Beta firmware Web UI setting “Forbid UIControl Service” which turns off the LCD?

    You might check if this is somehow being enabled unintentionally on your device and toggle it on & off to restart the UI service and see if it brings the LCD back online

    If it is a software issue the UI service seems like a possible culprit

    Otherwise it may be hardware as @Ali-Hadi suggested since it is abnormal


  • Hi @Derek-Saville - no, I haven't yet twiddled with any of the beta settings. I've enabled 802.11k and 802.11v in the non-beta settings since I was all happy to find options outside of the mobile client, but that was just because I was in the "what doesn't kill me makes me stronger" beta code mindset. Checking the UIControl setting is a great idea if the problem returns again.

    If @UI-AmpliFi has any thoughts about root cause at this point, they'd be appreciated, particularly since they've changed something between 3.4.3 and 3.5.0beta2 that seems (at least, more often than not) to change the behavior.


  • Hi @Derek-Saville - problem is back with 3.5.0beta2 and toggling on/off the UIControl setting did not resolve it. Likely I'll have to give up and accept that @Ali-Hadi is right....


  • So I ordered a new Alien and replaced the problem one, resetting everything in the mesh to 3.4.3 and starting over from factory defaults. No problem since. I set up the problem Alien as a satellite to test further and although I initially saw the LCD problem again, I haven’t seen it for a couple of days now. <shrug>


  • @UI-AmpliFi I’m having the same issue on 3.4.3. Remote reboot did not help, will now try unplugging but that’s of course not acceptable as a solution. Kinda disappointed to see these issues for a premium router.


  • @Michael-Aye Hi. This is a known issue and we have already prepared a fix in Beta release channel. The fix should be available in a stable version soon.
    You can either wait for a stable version or join the Beta program. Instructions are available above.


Log in to reply