Alien LCD Screen Showing Blank


  • Ended up here after my LCD would not wake up this morning on my Alien. Internet/wi-fi/mesh(2nd Alien) all working fine. I have not yet tried reset or Beta but will do so and report back.

    The second Alien setup as mesh is working just fine.

    UPDATE: enabled beta and restarted Alien...currently working as it should.


  • @UI-AmpliFi I received the replacement Alien router and MeshPoint pair yesterday and the LCD screen is working as expected.

    However, for some reason, I'm not seeing my gig (Comcast/Xfinity) speed in the router's speed test. As I'm getting 500+ Mbps and not the expected 940-ish Mbps. The router that was replaced showed the gig speed from the beginning. I should note that when I run the Ookla Speedtest on my iMac, Mac mini, and Apple TV 4K, and I'm getting 942-3 Mbps.

    Why would the Alien router be slower...? I also have the MeshPoint connected via ethernet backbone and the Mesh speed test is 900+ Mbps.

    And yes, I have tried restarting and factory reset(s).


  • @UI-AmpliFi

    Also having the same issue on the mesh point. Setup: 2x Amplifi Alien Router. Firmware: 3.6.0.


  • I also have this problem with the 3.6.2 version. IS there a solution to this problem?


Log in to reply