Alien WiFi Decreased Speed After Update to 3.4.0

  • Today I swapped from Comcast Cable 1Gbps DL/50 Mbps up to Ziply Fiber 1Gbps DL/1 Gbps up. During install noticed I had the 3.4.0 update waiting and ran it. Now my speeds have dropped by over 50% on WiFi only. Wired to Alien I get 980 Mbps DL/UL. From the wall I also get 900+ for DL/UL. I rebooted all devices with no success. Testing has been done on an iPhone 11 XS, iPad Pro, MacBook Pro 2019, MSI Stealth laptop, and two desktops running Asus WiFi 6 cards. Pre-update switch to fiber I got 500-800 DL no issue. Now It bounces on WiFi from 150-300 Mbps.

    Tests were run using,, and

    2_1596586800878_5D844E04-E3C9-4846-A33A-15B7F9B887DD.jpeg 1_1596586800878_5312ABA9-D077-4CDC-9C6C-FCCA27D1FBC1.png 0_1596586800878_18C3073D-ACE9-4458-B014-243262DCF65A.png

    I have tried flagging the Wifi 6 devices as gaming and disassociated and reconnected them to the Alien WiFi to no avail. I also flagged the Apple devices for gaming with no success.

  • @John-Eastman Since you made two changes and noticed the negative effect afterwards, lets try to manually roll your firmware back and test speeds again. If the speeds do not return on 3.2.5, it may be coming from your new modem/provider.

    Looking at your last image, it looks like full speeds between the Alien and the modem are at expected speeds, as well as the connection between your Apple Watch (iOS device) and the Alien.

    I will PM you instructions on how to perform the roll back and test.

  • @UI-AmpliFi

    Thanks for the quick reply. I am not sure why the Alien sees the end device as an iWatch as it was actually my iPad. It does the same thing on my iphone as well. I will do the rollback tonight and post findings.

    I did call the company and the modem is just the ONT and confirmed it is bridged not handling NAT or any other functions except converting the fiber to CAT6. Only router on network is the Alien.

  • Rolled back firmware with no joy. Speed is still extremely slow and is reminiscent of when I first got my Amplifi Alien where speeds were more in line with 802.11N speeds. Ran a test with my old Asus 802.11 AC router and all devices peak at about 700-800 mbps.

    Even running iperf I am seeing extremely low speeds when sitting next to the router.

  • @John-Eastman In some occasions where the IPS or modem was changed, a factory reset of the Alien has been known to restore performance. You can backup your system first if you have already created static IPs, port forwarding rules and family profiles.

    Can you let us know if a factory reset restores your performance?

  • I am having the EXACT same issue. DL speeds on Wifi 6 today were abysmal, 100 MBPS on GigSpeed service. Max I got today was 200, 3 feet from Router. I would love some help!

  • @UI-AmpliFi

    I tried factory reset after updating to the old firmware with no success. I also tried the newest update with a factory reset after it was installed and still no success. Testing on a CAT6a cable that’s 150 feet I also see wired speeds drop down to 600 Mbps but when I use a different router it jumps right back up to 980-950 Mbps. Not sure what is going on with this device but it has had issues since day 1 ever achieving the advertised speeds.

    It’s disappointing because the first Amplify had initial issues but shortly after it got updated and was great. This one seems to have more issues and still not working right. Also still waiting on 160 hz broadcasting which might hopefully solve the WiFi woes.

Log in to reply