No WiFi, Limited Range and Router Not Saving Settings


  • Before the new problems get blamed on the Power Outages here in Connecticut, the Router, Modem, Computer are plugged into a Cyberpower 1350 backup UPS which does not show any issues (less than a year old Nov 19 purchased). Now the Aliens I purchased in December of last year is the dual pack. From December of last year to this month the only problem I had was around April getting the Alien to recognize the modem. The topology has not changed, everything was running great, I had solid WiFi within the whole house anywhere I went with 1 router and 1 mesh point. As long as it is up and running I do not play or adjust settings, occasionally I will run Speed Test to make sure I am getting what I paid for from Cox Cable. So following the directions I received from Support in my other recent post I got the system back up and running by starting the Alien first then connecting modem. After it was up I checked WiFi on my iPhone 11 Pro Max in the same room as the router and everything worked or so I thought.
    Went downstairs to setup ring devices I have and ring would not connect to the network. Checked my Wifi and it showed No Internet Connection, I was on LTE. I was downstairs about 20 feet from the router and no wifi. Checked the Amplifi Settings and added the SSIDs for 2.4 and 5. Improved the Wifi but the problem is ring devices will not recognize symbols in the WiFi name so just dropping the 2X or the 5X from the SSID will not work as part of the name still has a dash in it. Tried to remove the Common SSID's and when it saved went back into the Amplifi Settings and the Common SSIDs was green again. It will not allow me to change it.
    From setting this up in December of last year I have always run my computer through a D Link Switch along with my Cox Security Gateway/Modem and never had a problem until updating the Alien Firmware this week. If my computer is plugged into the Switch it is assigned a Private IP and will not work over the network. Plug it into a Ethernet Port on the Alien and it works fine. The Cox Security will also not work on the Switch now but will work when plugged into Ethernet Port on Alien. Tried a new Netgear Switch out of the box and same thing, devices will no longer work through the switch plugged into an Ethernet Port on Alien. Everything worked prior to updating to latest firmware. This applies to both units acting as Router. Tried them both yesterday.

    1. Am I able to revert the Aliens I have to earlier Firmware and give this another go before I ask for an RMA?
    2. If I cannot change the Firmware, I am not sure what else to do as this was working flawlessly prior to last firmware and now it is not.
      Sorry for lengthy post but Summary of Problems: Weak or No WiFi where I previously had WiFi, Settings will not stay in Router when saving.
      Could be a fluke where I am having hardware issues on both units but I kind of feel that I had a bad firmware update this past week which would have affected both.

  • @James-Kelly said in No WiFi, Limited Range and Router Not Saving Settings:

    Am I able to revert the Aliens I have to earlier Firmware and give this another go before I ask for an RMA?

    This is a great test to try before submitting an RMA. I have sent you a PM with instructions. Please download support files from your system in its current state while experiencing these issue so we can compare and identify the change in firmware that caused this if any.


Log in to reply