IOS 14 feature «private adresse» slows down network speed

  • The new IOS 14 feature «private adresse» (read about it here: slows down the wireless speed by a huge amount. Turn it off on your IOS device to double the speed.

  • Update: after 20 mins the speed on the Amplifi HD drops down again. So perhaps this was a false hope of getting iOS devices up to speed on the Amplifi HD.

  • @Steffen-Pettersen iOS 14 is still in beta. Use the Feedback app to pass this on to Apple, as this is a bug in the beta operating system and Apple is the only who can fix this.

    I’m using an iPhone 11 Pro Max with the iOS 14 beta using the AMPLIFI Alien router and am unable to repeat this, so definitely pass this on to Apple with the Feedback app.

    You may also want to reboot both your HD router and cable router, especially since the issue disappeared and then reappeared. It’s also recommended to reset your Network Settings on any mobile device after an operating system update. Go to Settings>General>Reset Network Settings.

  • @Richard1864 I do not think this is a Apple bug.

    I can force this bug every time I switch off and then back on the Private Adresse. The speed will be high for the first speed test, then drops again. Until I switch on or off the Private Adresse function again. Then it is fast, for one or to two speed tests, and it drops again.

    I have a screen recording showing how i can force the error. So if support is interested, let me know and I will send it to you.

    This is very much alike the overall problem I have with the Amplifi HD; iOS devices drops speed and become very sluggish over just a short amount of time.
    This is also the case on my iPad running latest version og IOS 13, and my son’s iPhone 11 Pro also running non beta iOS.

    I use a iPhone 11 Pto just upgraded to IOS 14 Public Beta 5.

  • @Steffen-Pettersen if you have devices that are NOT repeat NOT running the iOS 14 beta also having speed problems then the iOS 14 beta is NOT the source of the problem. Either way, you still need to report it to Apple via the Feedback app so that Apple is aware of the problem.

    Because iOS 14 is in beta, and NOT a finished product, there is very little AMPLIFI or anyone else can do to troubleshoot it, that’s why you need to report it to Apple. Apple actually REQUIRES you to report those issues when you agreed to do the public testing.

  • Because I can’t repeat the bug means there is something peculiar in your network causing the issue, that’s all. Please, report the bug to Apple via the Feedback app; like I said above, Apple is the ONLY one who can troubleshoot it right now because iOS 14 is in beta. MAC addresses are used to identify your devices to the network. That’s all they do.

    All the private network does is protect your privacy by giving out a different MAC address than the one built into your iPhone. That has nothing to do with network speed.

    You say your iPad with iOS 13 is having the same issue, but it does NOT have iOS 14 on it. That means no private network setting, thus something else OTHER than iOS 14 is causing the problem.

  • I see no change in speed with Private Network turned off on our iPhones with iOS 14 beta, nor do I see a loss of speed with it turned on. That’s why I’m saying I can’t repeat your issue and that’s something else could be causing it. That’s is also another reason to report it to Apple via the Feedback app.

    Have you tried rebooting your router, or resetting to defaults? There could be a router setting causing the issue. Have you tried resetting the Network Settings on your iOS devices? You don’t mention if you’ve tried that yet. There is very little that can be done to troubleshoot iOS 14 problems because it’s in beta.

  • @Richard1864 Please spare me the tøying in capital letters snd stop tryong to instruct me what to do.

    I am takling about Amplifi HD (not Alien) and the HD have had known issues with iOS devices since v3.2. So I find it better that support try this out, not you.

  • @Richard1864 I'm not seeing this either on my two devices that are on iOS 14 Developer 5. One currently has the private address on & one doesn't... both achieve the same speed.

  • @Steffen-Pettersen I have tried to duplicate this on my own AMPLIFI HD and AMPLIFI Gamer’s Edition using my iPhone 11 Pro Max w/iOS 14 Developer Bets 5 (which is the same as your beta), and I can’t duplicate the issue. Apple Developer Technical Support (I’m a Developer) suggests checking your network password, making sure it is only using letters and numbers because special characters like “#” and “?” can cause the problems you’re seeing. The Tier 3 tech also said to report the problem via the Feedback app, that no one else has reported this issue yet.

  • @Steffen-Pettersen While iOS 14 is still in Beta I would not expect Amplifi to spend much time on this and other IOS 14 related problems. Doing so will take away time for Amplifi to work on problems that are plaguing released versions of both Apple and Amplifi software. Amplifi should be notified but not be expected to fix them while IOS is still in Beta. They could fix the problem only to have it cause other problems in already released software and even the final released version of IOS because Apple implemented a change the was the root cause of the problem.

  • @James-Ford agreed. It’s the same with the other networking and peripheral makers; they can’t provide much technical support for any operating systems that are in beta. Thus, why it’s always strongly advised to pass on those issues to whoever made the operating system (Apple, Microsoft, Red Hat, etc.).

  • @Steffen-Pettersen Are you still having this problem now that IOS 14 has been released?

  • @James-Ford No, still the same. System slows down after 48 hours. Must restart manually all APs and the router. This is a very bad product, snd the support are even worse.

  • Well, so I still can’t repeat this issue. And I’m also testing a Netgear CAX80 cable modem router combo for work, and the iOS private address isn’t causing any issues there either.

    I’m sorry, I don’t know what to tell you for ideas in fixing the issue.

  • @Steffen-Pettersen We have also not been able to replicate this in the lab. Do you happen to have any settings on the web UI?

  • I can confirm this issue exists with Ameplifi Alien. tried Samsung Note 20 Ultra, iPhone 12, iPhone 13 Pro, and iPhone 8. All have the same issue. Very slow wifi speeds when the private address is enabled. I get around 800-900 on WIFI 6 without private address enabled and close to 100 MB with the private address enabled. I need to enable this in my Windows laptop to see if there are any issues, right now it is disabled. I do not have another WIFI router to test this but I might get one and return it. So far all good as long as private address or random MAC address is not enabled.

Log in to reply