Confusion over multiple subnets

  • I've just added a pair of Amplifi HD routers to my home network (description below) and I dont understand how to configure the network to operate as I expect. I'm looking for some assistance in the setup to resolve a few questions.

    {lots of wired devices via DHCP}
    Lounge TV (DHCP)
    HP1910 switch
    Synology NAS
    Amplifi HD router
    Amplifi HD as mesh point (?? using backhaul)
    PlusNet router (wireless disabled - provides DHCP & internet)

    Amplifi HD router
    Kitchen TV
    Phones, laptops, lightbulbs, Alexas, etc


    1. Do i need two subnets? I'd like to replace the plusnet box, or at least relegate it to just being a VSDL modem. I dont know if that is possible, but I can/will buy a Draytek 130 if that would help. I think a lot of my problems are caused by multiple subnets...
    2. Devices in the wireless network cannot access shares on the NAS by undecorated name, but need a .lan suffix. Where did this come from? How can I configure this away, as it breaks lots of device configurations?
    3. Selecting Youtube videos from the phone (wireless) to play on the lounge TV (wired) has broken. Wireless devices can now only see the Kitchen TV (on the same subnet), and not the Lounge one. What device needs to be configured to enable casting between subnets?
    4. In order to connect the second router as an access point, I have to plug it directly into the back of the first router, which requires an extra cables to be run to it (and weirdness at the patch panel). Plugging both into the HP1910 switch does not work, though the documentation suggests it should. What needs to be set on the switch?

    I know that's a lot of questions, but I'm out of my depth...

  • Hi @Jim-Chaney - it looks like you might be in a Double NAT situation

    While your PlusNet is functioning as the DHCP router, you will want to enable Bridge mode on the first HD router...

    Then you can install the second HD router as a mesh point (wireless or wired backhaul work)...

    This will create one single meshed WiFi network behind your PlusNet router

    If you relegate the PlusNet to just being a VDSL modem, then you would put the primary HD router into DHCP mode, using PPPoE if your ISP requires it, and the 2nd HD router would still work as a mesh point

  • Thanks @Derek-Saville, it sounds as though Bridge mode is definitely in order somewhere.

    I would have preferred to cut down the duties of the (PlusNet) One Hub, but according to their community site it isn't possible to use that device purely as a vdsl modem (

    The QoS and Family Profiles are the only features I would miss, so I'll try Bridge mode on the Amplifi HD first (but not until tomorrow, it's ~1am now). If that doesn't work out, then I'll go find a new modem.

    I had one other question, but my edit got lost...

    When setting up the second router as an access point, it worked fine over wifi, then fine when switched to ethernet (into back of primary), but when connecting the AP to the switch instead of the router directly it no longer connects. I understood this should be possible; is there some setting in the switch required, or do I have to run multiple cables to the primary and then get creative at the patch panel to hook the AP directly in? Seems flawed, especially if I need a third AP (eventually, I'll run out of ports!).

    Appreciate the assist!

  • Hi @Jim-Chaney - was the switch connected to the LAN side of the primary HD router or the WAN side?

    If the HD was not in Bridge mode, and the switch is on the WAN side of primary HD, then the Ethernet backhaul probably wouldn't work through the double NAT

    If you place the HD in Bride mode, then it should work though the switch no matter where it is located

    The router as a mesh point (RAMP) need to have its WAN port connected to the LAN side of the primary HD, with no NAT or obstruction in between, and AmpliFi always recommends a physical connection this way

    So if you connect them directly with one cable, it will always work

    If you are going through switches and the WAN port of the primary HD, people have reported it works this way, but you need to be in Bridge mode

  • @Derek-Saville thanks for your time. Hooking up the device in bridge mode has resolved everything, including the ethernet backhaul from the RAMP.

    I'll play with the settings and see where it leads, but you can consider this 'case closed' 🙂

Log in to reply