Mac slow through mesh point, other devices fine

  • Bit of a weird one this, and I was hoping somebody could help me diagnose. So I finally have my mesh points set up so they run in daisy chain mode (that took me days to figure out the best combination of turning on/off the mesh points and changing from 2.4GHz to 5GHz in the right combination to bypass the shitty algorithm that was deternined to connect my furthermost mesh directly to the router at abour 20% signal strength, d'oh). Now all is ok and I can wander around my whole property and get consistently above 80-90Mbps anywhere (when testing from an Android phone). Brilliant.

    However... if I connect my Macbook Pro (2020 13", plenty capable) or desktop Mac to either of the mesh points, I only get 20-30Mbps at maximum. I have verified they are connecting to the mesh point via the topology diagram, and I can literally sit in the very same spot with my Android phone, or a Windows laptop, connect to the same mesh point and get 80-90Mbps. If i connect my Macbook Pro direct to the router via WiFi it'll happily get 200Mbps+. It's only via the mesh points that it slows down completely.

    Even weirder is that my upload speed is around 40Mbps on my fibre connection, and even when the Mac only gets to 20-25Mbps down via the mesh points, upload is always able to saturate completely at 40Mbps.

    What could possibly cause the speed on the Mac to be so slow vs other devices, but only when connecting through the Mesh points? (it's the same in bootcamp under Windows). Cheers in advance for any help!

  • Hi @Manny-Brown,

    I have An Amplifi HD standard setup with two mesh points. My incoming internet is a fibre connection 250/100, I have no router or modem before the Amplifi router.

    I have, as you, different devices, Mac, iPhones, Androids and Windows.

    Regarding my Mac devices I cannot complain on speed. I have "hard wired" my Mac devices to specific mesh points.

    On upper floor I have my Mac Mini (2014) connected to a dedicated SSID for 5Ghz and on that device I got around 200Mbps down and 90Mpbs up.

    On the lower floor I have tied my iPhone 7 Plus, iPad Pro and Macbook 12 (2015) to another 5Ghz SSID. On those devices I got between 130Mpbs/200Mbps download - depending on the distance to the Meshpoint. The lower speed is when I'm in my home office that it's separated from the main house. The signal then goes through two wood walls and it's a distance around - 20-30m to the mesh point.

    I think the above speed is OK during the circumstances.

    Although, I did had major performance problems earlier as many others.

    I did checked out the interference from other wifi networks and changed channels due to that.

    I also changed specific settings on the Amplifi router.

    -Band and Router steering is off (change this in app)

    On the settings (webpage for router) for network I have the following setup:


    I also run the latest FW and I have had no issues. For me the system is as stable as it was before the 3.3.0 FW release.

    I'm also part of the beta community and testing both FW and App.

    If you have any further questions, please let me know.

    Information is as is.

    All the best,


  • Thanks for this. I'll try and replicate your settings, see what I get.

  • Unfortunately I still have the same issue after trying those settings. Standing here testing on my phone now I'm getting 70Mbps, while the Macbook right next to me can only hit 19Mbps, same on the iMac. All going through the same mesh point. It's really bizarre.

  • Hi again @Manny-Brown,

    Sorry to hear that it's still problem for you.

    I might asking you something that you might already have considered.

    Have you created a dedicated SSID on 5Ghz network on the mesh point you wants to connect to?

    See my picture below on my setting, my SSID = AmpliFiLower:


    All the best,


  • I have already tried that yep, unfortunately with still the same results. Thanks for the suggestion though. I can see via the topology graph that the Macbook and the iMac are both connecting to the mesh point at 5GHz, same as my phone, just with a third of the download throughput.

    I'm considering picking up a USB WiFi adapter just so I can rule out the chipset on the Apple devices in some way, but as mentioned, if I connect the Macbook or the iMac direct to the router via 5GHz WiFi, I get full throughput without any issues, so the performance throttling is limited solely to the mesh points. Very bizarre.

  • Hi @Manny-Brown,

    Sorry to hear that. I wish you all the luck. Please keep us posted how it works out for you.

    All the best,


  • @Manny-Brown Is the Mac only using a 1x1 connection?

  • @UI-AmpliFi I'm not entirely sure how to check, but as an example, while I'm sat in my front room with it connected direct to the router on 5Ghz, I'm getting a Tx rate of around 975 Mbps, sometimes up to 1175 Mbps. I'd assume that would mean more than 1x1? If there are other ways I can check then please let me know.

  • @Manny-Brown Hi, Manny - I have just just set up a Mac on a mesh, and I have exactly the same problem you described. An iPhone sitting next to the MAC gets 200mbps download, but the Mac (using google speed test) doesn’t get above around 20. Did you find a solution? I’d be very grateful for advice.

  • @Guy-Ashton I didn't unfortunately no! If I connect the Mac directly to the router on WiFi it runs full speed, so definitely something strange going on with the mesh points. I just sort of gave up on it in the end, tried all sorts.

  • @Manny-Brown Thank you for your response. I’ll stop trying and look for another way!

Log in to reply