Slow LAN speeds and variable testing speeds


  • I have Charter/Spectrum 460 mb/s and when connected directly to the Ethernet port through the Amplifi router I am getting roughly 100 mb/s download speeds on speed test, same with using my iPhone 11 Pro. However, when using Amplifi app it shows the advertised speeds, and I can see it spike on the router to these speeds. The speed test on the router shows 100 mb/s. Customer service is not able to help. Directly connected to the modem I get the advertised speeds. I’ve tried a different router, which reached advertised speeds. I tried different Ethernet cords with no improvement. Please help!!

    Fast.com on iPhone
    Router speed test
    Amplifi app on iPhone
    Router spike when testing with Amplifi app


  • @Jeremiah-Parve
    What are you using as a test machine...? You stated you are connected via ethernet, and I know that can't be the Iphone 11 Pro. 🙂

    Have you tried a different switch port on the Amplifi router? This sounds like a ethernet negotiation error IMO. Sounds like something somewhere is only negotiating @ 100/Full vs 1000/Full.


  • @Anthony_014 using a custom built desktop PC, only iPhone 11 Pro for WiFi 6 testing. Have tried different ports and Ethernet cables without any change. When I connect up my old Asus ac2300 I’m getting advertised speeds. Any suggestions? I’m on firmware 3.4.1.


  • @Jeremiah-Parve
    Well, in your troubleshooting is certainly does seem that the Amplifi router is the bottleneck for whatever reason. Since this hardware is still in Beta-ish stages, I would try to factory reset the router and re-configure.

    Another thought, It could be that the WAN port on your Alien is defective, causing only a 100/Full ethernet negotiation. Do you have the ability to log-in/manage your gateway device from your ISP? I'd be curious to see what the link negotiated speed is between it, and the Amplifi when connected.


  • @Anthony_014 unfortunately, I do not have the ability to login to my ISP and negotiate the gateway. I’ll try a factory reset. I also thought it was defective LAN ports, but after further investigation on Reddit and community forums it appears this is a known issue, thus I suspect it’s a firmware problem.


  • @Anthony_014 solved, the QOS settings on the router webpage were set to 100 mb/s download and 50 mb/s upload. I adjusted them and now everything works perfect. I thought it was correct, but it was in kb/s and realized I was a couple of zeros short. Glad it was an easy fix. Thanks for the help.


  • @Jeremiah-Parve
    Ah! Good find... That will certainly do it! You had the "Optimize Latency" setting on, huh...?

    Cheers! No problem!


  • @Anthony_014 would you recommend turning it off?


  • @Jeremiah-Parve
    That feature limits each connected device to 100 Mbps to try and help with increased/latency spikes due to bandwidth saturation.

    Because of that, I figured you already had it enabled, unknowing of the above. Lol But yes, I would recommend turning it off for sure! It does nothing to actually optimize latency aside from auto apply a 100 Mbps global QoS rule that all devices must participate in.


Log in to reply