Slow wired and wireless throughput


  • I am using the AmpliFi HD router, hardware ID 19, firmware version 3.4.2 I have another HD router with the exact same specification. Both routers were purchased through the EU Ubiquity store and are part of the AmpliFi HD Mesh system. For the purposes of this test, mesh points are not in use.

    A 1Gbps wired client is connected to the HD router, which is running in router mode. A MacBook Pro is connected via wireless (5GHz, 80 MHz) and is physically close to the router. Running an iperf3 test reveals the followig: the 1Gbps wired client gets ~220Mbps throughput to the HD router; the MacBook Pro gets at best ~350Mbps. Why are those numbers significantly less than what is theoretically possible? We could ignore wireless because of the many complexities around it, but getting less than 300Mbps on a wired 1Gbps connection sounds wrong to me. The other HD router exhibits the exact same behaviour. I have tried bridge mode, I have tried changing various settings - nothing got me a better throughput. For the record, I have an Apple Time Capsule; I connect the 1Gbps wired client with the exact same cables and my MacBook Pro via wireless (again 5GHz, 80MHz) and the numbers are significantly different - ~990Mbps for the wired client and ~600Mbps for the MacBook Pro. I tried with hardware NAT off and on - it didn't make much of a difference.

    I searched through the community forum for similar throughput problems and there are plenty of them. I would guess the Ubiquiti engineering team is already aware of this recurring issue and hopefully it can get resolved soon. Also for the record, I tried reverting to a previous version of the firmware through the web UI, but I saw a "Rollback not possible" message - I am not exactly sure what that means.


  • My ISP promised us next month 1Gb/s connection.
    So i hope i will get wired connection at least 900 Mbit/s.


  • @dharalanov I am also getting really slow speeds lately. I'm not sure if it has to do with the last update but I'm also running 3.4.2.
    I exchanged my modem but to no avail.

    I also have 1gig connection from the internet provider.

    My wireless speeds are faster then my hardwired speed. I was just about to go out and get another router just to test out, but it looks like you are having the same problems Im having. I get nowhere faster then 200mbps in wired and up to 400mbps wifi.


  • I contacted the support team and their response was:

    The speed observed between RPi4 and MacBook Pro represents the actual capabilities of HD. For faster internal speed we have the Alien model.

    My MacBook Pro is the only wirelessly connected device to the AmpliFi HD router. The Raspberry Pi 4 has a 1Gbps ethernet port. I find it ridiculous that 1Gbps wired devices using the router as a switch achieve less than 300Mbps throughput. Wireless performance is also significantly below the advertised (theoretical) throughput, but let's say interference could be a problem (although I tried much cheaper wireless routers and they outperformed the AmpliFi HD in terms of throughput in the exact same setup). But suggesting to buy a device, which is more than twice the price of the AmpliFi HD router while having same advertised wired performance is just absurd. And what if I buy the AmpliFi Alien and the performance is the same? Is the support team aware that other people experience similar performance problems with both AmpliFi HD and Alien? If this is a software problem then it should definitely be looked into.


Log in to reply