2.4GHz-only client can't connect/Network Not In Range

  • Hi, All.

    What solutions are you guys implementing to deal with situations like this?

    I've been using this thing for my 'travel router' (when I stay in hotels, etc) for a couple months, and although it's obviously not UniFi (which I've been using personally, and installing for my IT clients for years), I do actually like it.

    However, I'm attempting to add a new device that only has 2.4GHz Wi-Fi adapter, and it is the only device that won't connect.

    It just says 'Network Not In Range'.

    This new device is a Walmart Onn branded Android Tablet. It's the Gen 2 of the 10.1 non-pro version.

    Goofy thing is that I also have a Gen 1 of the same thing (with almost identical features), and it connected just fine.

    I think I kind of know what's going on... seems similar to the problems we had with connecting the original Google Chromecast devices to Wi-Fi in a context where the Wi-Fi network used the same SSID for both 2.4 and 5GHz networks.

    Why the hell, with such an otherwise great product line from such a great, advanced, professional company would we not be able to separate them on this thing by having different names for each SSID? It's just nuts!

    I know that I can add an additional SSID, but there is no way to hide that SSID.

    I know the arguments.... "Hiding the SSID is not a security measure."
    That would be true IF privacy weren't also security.
    The more details about me I can keep hidden (I know they can get to it anyway, but that's not the average person....the average person can see when a new SSID shows up in the RF space, and will automatically know it's coming from the guy who just checked in.), the better.

    The only way around it would be to name the SSID something that is not in any way personally identifiable. I can do that, but it just grates on me that I can't do either of these two things; separate the SSIDs by name, OR hide the additional SSID.

    To be clear, any attempt to argue with me about the way I see the whole privacy/security argument mentioned above will be ignored, because that's NOT what I want to discuss.

    I will most likely be returning this tablet, but I figured I'd check here first, in case anyone has a viable solution for these issues.

  • @uniphi My RoboVac with 2.4ghz couldn’t connect.
    Then I remembered that 5ghz not as good in long distances.
    So I took it outside and opened the app + did the setup with no problem

    My RoboVac is next to the router and working great since lol.

    You can do that or create a separate wifi with 2.4ghz only .. coming with the next update if im not mistaken

  • @Kayan-US
    Hey, thanks! 🙂
    I will give that a try...

    Well, it has become very obvious that this problem is NOT the tablet's fault...

    I just bought a new set of color LED bulbs. They are 2.4GHz Wi-Fi only, and they won't connect either.

    THEN, I noticed that my AmpliFi router had been up for over two weeks (HA! Not that that's a long time for professional equipment, but this thing is not quite 'up to par' in that sense.).

    So, I rebooted it.

    After the reboot, the new bulbs were able to connect.

    One other thing I should mention...
    When I connected those new bulbs, AND upon connecting some other 2.4GHz-only devices to this router, they popped up a little msg box that said,
    "We can only connect to 2.4GHz Wi-Fi channels (not 5Ghz)"

    Now, it also had a link to click named "Change network" (i.e. So that I could show it how to find the 2.4GHz one, but alas, that's not possible with this thing). 😕

    At that point, I simply clicked the big, blue'Confirm' button, and it worked.

    So, rebooting the AmpliFi router clearly fixed some kind of glitch, but not well enough to enable the 2.4GHz tablet connect. 😕

    [Assume I know nothing lol ]
    If you were to attempt to figure out why 2.4GHz devices suddenly can no longer connect (whereas they were able to previously on this exact system within the past week), where would you look?.

  • Hi @uniphi - have you tried disabling Band Steering?
    Using the WPS interface if the tablet supports it?
    Are you manually setting the 2.4 GHz channel to 1, 6 or 11 (non-overlapping)?
    As a test (we know you won't use the feature for real) have you tried connecting to an Additional 2.4 GHz SSID?
    Would you be willing to join the Beta program from the Web UI and then disable the 5 GHz radio altogether?
    Maybe turn everything on and/or off in the Web UI?

  • @Derek-Saville

    "Hi @uniphi"

    First off, thank you, very much for taking the time to assist like this. I really appreciate it. 🙂

    "...have you tried disabling Band Steering?"
    A: Yes. I wondered if that could be going overboard on its task, but disabling it didn't change it.

    "Using the WPS interface if the tablet supports it?"
    A: I haven't yet. Based on the results of other similar/related testing, I kind of doubt it will be the solution (i.e. it may work to connect, but might not actually stay that way since WPS is really only about making the initial connection, and I don't think it has any maintenance functions), but I will give it a try.

    "Are you manually setting the 2.4 GHz channel to 1, 6 or 11 (non-overlapping)?"
    A: I manually, individually tested every single channel. No difference on any of them.

    "As a test (we know you won't use the feature for real) have you tried connecting to an Additional 2.4 GHz SSID?"
    A: Yes. It worked just fine. So did setting it to broadcast the name of the 'normal' SSID.

    "Would you be willing to join the Beta program from the Web UI and then disable the 5 GHz radio altogether?"
    A: Yes. Absolutely.
    I actually already chose to join the beta in the app, but when I checked for updates, I didn't see any available, and haven't noticed any changes. I will go check again.

    "Maybe turn everything on and/or off in the Web UI?"
    A: OK. I will poke around and see what all I can turn off and back on again.

    Thanks again. I will report back with an update on the testing suggested above...

  • "As a test (we know you won't use the feature for real) have you tried connecting to an Additional 2.4 GHz SSID?"
    A: Yes. It worked just fine. So did setting it to broadcast the name of the 'normal' SSID.

    Hi @uniphi - this makes it sound like the devices just don't like common mesh SSID's and management

    Someone mentioned they are going to implement separated main SSID's similar to the Alien in a future update and that should solve the problem without needing to create an additional SSID

    You might want to send a direct message to @UI-AmpliFi asking if that will be the case, or maybe they will respond here to confirm separated main SSID's are coming to the HD & Instant range

  • @uniphi By using a common SSID we can steer devices connect to 5Ghz rather than 2.4Ghz. Creating an additional SSID for 2.4Ghz will solve your IoT device connection issues.

  • UPDATE: Interesting development...

    OK.....first....I never said I'm not an idiot. lol
    It's always good to get that out of the way early (sorry I waited). 😉

    For some reason, I decided to do one more (this time exhaustive, I thought) look through the settings on the tablet to see if there is something I was missing.

    There was...

    In the Wi-Fi settings, when adding a new Wi-Fi network, in the Advanced section (which, unfortunately, I hadn't gone into previously), there is an option to enable for dealing with hidden SSIDs (Now that I found it, I do recall having seen a similar setting on other Androids in the past, but it just didn't come to mind).

    Well, once I enabled that option, it connected.

    It is now happily connected to the 'regular', hidden, 5GHz Wi-Fi network SSID.



    1. This problem never had anything to do with a '2.4GHz-only' issue.
      If I had known that this tablet actually had a 5GHz Wi-Fi adapter, I assume I would have gotten to a solution quicker, but this was OK. I really appreciate you guys stepping up, and assisting me with kindness and respect.

    2. This problem was clearly the fault of the merged SSID configuration of the AmpliFi router.

    QUESTION: Does AmpliFi HD allow separating the SSIDs, AND leaving them hidden?

Log in to reply