Don't buy a wifi6 router without a good portion of beneficial features. Lesson learned!


  • This post is deleted!

  • This post is deleted!

  • @unseenone Thanks


  • Forget about the user above, and he/she deleted their post. You and Anthony were having a perfectly respectful conversation. On to your speed problems, are you in a congested WiFi environment? I have about 50 devices connected to my network (1 router, 1 mesh point, and 1 RAMP) and get a little over the advertised speeds. I get 480/25 and advertised is 400/20. Great coverage throughout the house and front/back yards + some. I live in a suburb of San Diego with homes up and down the street (basically your typical neighborhood/home), so there are other networks around me that I can pick up on NetSpot.

    I have all radios enabled, under the same SSID, band steering on, and channel selection on auto. In the beginning I set NetSpot to monitor all networks and mine for a few days to see how well the channel selection was on the Alien, and it was great. It switched when it should and a channel became a bit congested. Since then I've left it on auto without any issues, even 2.4 GHz smart devices that would constantly lose connection before on other routers, don't have any issues now. And I have all Aliens on wired backhaul on MoCA. Have you checked all the settings above?


  • @iamaydo I'm in a very congested area. My settings are pretty much the same. I know now it's just the congestion as my older router that use to do great is now pretty bad speed wise.


  • @Mike-P Maybe give a WiFi scanning app a try to find non-congested channels and set them manually in-app and see how that goes. That might just solve your issues. Your other hope, along with many others is for AmpliFi to add support for DFS channels.


  • @iamaydo There is no way to manually select a channel for the wifi6 channel.


  • @Mike-P You're right, I meant selecting the WiFi 5 channels. Just some ideas to try and help with a crowded WiFi environment.


Log in to reply