Device Switching Between Router and MeshPoints


  • We've performed a successful setup of our Amplify HD router and two mesh points in our 2,200 sq. ft., two-story home, and have successfully registered our various laptop computers and devices onto the network. We're getting an excellent 5 GHz signal in all parts of our house now.

    The problem we're having is that our devices do not seem to automatically move from one access point to the other. Once connected to, say, the upstairs mesh point, a device will stick with this access point, even when moved to the close proximity of the router or another mesh point. Manually disconnecting and reconnecting to wifi will work to force a transfer between access points, but we were expecting an automatic transfer from this system.

    Any ideas about how we can troubleshoot, fix or work around this issue? Our thanks for your suggestions.


  • You might have good strong signal to both the router and the mesh point so your device doesn’t see the reason to switch. That would happen if the mesh point is too close to the router

    Try reposition mesh points moving them further from the router

    Also you can try enabling all 802.11 options in the web UI


  • @Timofey-K

    Appreciate your suggestions, thanks. The wifi signal is strong near the router and two meshpoints (-40 dBm), but then can drop as low as -75 dBm as we roam our devices to other parts of the house — all without triggering an automatic switchover to a new access point. We can always initiate a manual switchover, however.

    We will look at the 802.11 options available in the web UI, as we haven't found any options in the Amplify mobile app that might be reconfigured to help with our problem — though there may be options here that we're not aware of and should try.


  • On the app, you could also enable "router steering"....


  • To update: As suggested by Timofey K, we enabled all the 802.11 options in the web UI (.11r, .11k and .11v), along with "Enable automatic backbone band switching," which was on by default. This seems to help! Our devices will now automatically switch to the new, stronger access point — however, one has to be quite close to the new access point (within 10 feet) for this to happen. Perhaps there's more we can do to improve the range of this automatic switchover?

    We will also try enabling "router steering" on the app, as suggested by Raghu Kannan, when we have more time to experiment. Thank you for all your help and any further suggestions.


  • @SimpleGift Make sure the router and MeshPoint are far enough away from the routers so they are not overlapping to much. To much over lap will make clients have a harder time switching to a different AP.


  • @UI-AmpliFi I suspect this is our situation. Our house is just large enough to benefit from a mesh system, but not quite large enough to get the mesh points far enough away from the router for seamless automatic switching.

    We tried enabling "router steering" in the Amplifi app as suggested upthread, and this helped a bit, but only in one direction. Auto switching works great now from a meshpoint signal to the router signal, but still needs manually switching when one wanders away from the router in the direction of a distant meshpoint.

    My sense is we may just need to live with this behavior in an otherwise excellent, rock solid and much appreciated wifi system from Amplifi.


Log in to reply