AmpliFi HD Firmware v3.4.3

  • AmpliFi firmware v3.4.3 for AmpliFi HD, Instant and Teleport hardware has been released.

    Release notes:

    • Stability fixes
    • Performance optimizations
    • Fix for Teleport connection related crash
    • Send anonymous kernel crash logs to Ubiquiti

    We use a gradual rollout and it may take up to a week for the devices to receive this update.

  • Hi all,

    Just updated and will monitor it for a couple of days. If any issues I will let you know.

    All the best,


  • @UI-AmpliFi

    I can't se update 3.4.3 for my amplify HD ?
    Is there a way to download I manually ?

  • This rollout seems to have broken my everything. Lost connectivity this morning during school hours (>.<) Did the unplug and plug back in, it came on for a few minutes and then dropped right off again. Devices connected via ethernet aren't being assigned ips, wireless devices are not seeing the updated [pihole] dns that I carefully put back into place while things were up those few minutes. All devices are seeing the xx.xx.xx.1 intro dns from the reset. I've reset their network settings, I've tried rolling back the amplifi and setting it up exactly as before the update but now nothing will stay online and the amplifi keeps losing connection and then coming up for a minute or two and then down again. There's definitely connectivity via our provider, the amplifi IS showing the correct dns through the app and online, but devices are still showing the xx.xx.xx.1 intro. I'm just frazzled at this point. I'm going to grab the Asus dark knight out of the hubby's man cave and see what it has to say. I'll keep this forum posted if anything comes up.

  • @Alex-Driven as per the post above:

    We use a gradual rollout and it may take up to a week for the devices to receive this update.

  • @Samantha-Duthie that doesn’t sounds good, what version are you updating from?

  • This also broke my everything. Tried a reboot (which worked last time the update broke my network) and try a factory reset. None of the ports work except for port 1.

  • @Jonathan-Peterson I knew it.
    I hate to say this but it is the truth: ever since 3.4.1 until now - nothing has worked.
    When will they release a functional firmware.

  • Works perfectly well for me. Wifi throughput seems to be higher on 5GHz in the same spots but that could be because of the new phone

  • Updated remotely from RC1 without any issues other than a nest camera that wouldn’t connect at first. Turned off band steering and it connected to 2.4Ghz. Performance is as expected. Will monitor.

  • @Eric35 you mean since 3.1.2.... really sad. I’m hoping but after so long its almost pointless.

  • @krvst8 @Eric35 I do not agree. Coming from 3.1.2 I upgraded to 3.4.2 about 2 months ago and am using it since then without any problem. However, there will always be specific setups which might run into issues. That’s where we need Ubiquiti Support and where others in this group maybe can help.

  • @John-Meinen-0 lol have you read these forums? Apple device slowness issue since firmware I referenced from 2019! Never had a problem with any firmware 3.1.2 and older.

  • @krvst8 He said there will be specific setups that will run into issues. Could what you are seeing in terms of problems be related to Apple devices also rather than just the AmpliFi? I don't know but just saying...

  • @Ali-Hadi It's not just Apple devices that drop issue - also Android devices!!!
    So yeah i think you might be wrong on this.

  • @Eric35 - just as it is wrong to automatically assume issues reported on a support community forum are applicable to all installations

    I have 5 sites, 2 of which are still HD series

    I also help other expats with Teleporting, primarily now router-to-router, so 2 to 3 installs per user

    Out of 40+ HD sites running the the gamut of client devices, multiple mesh points, multiple ISP types, etc., there have been zero complaints or issues reported with the last five firmware releases, although I did encourage everyone to hold on v3.1.2 as long as possible

    So unless you have telemetry data to share, you are no more right than anyone else

    This community totally understands the frustration AmpliFi issues can cause, me included, but they don’t apply to everyone

  • Running 3.4.3 since two days with one router, one RAMP and one meshpoint without any hiccups.

    The only thing wrong seems to be the integrated speedtest, which consistently results in values too low (70 instead of 110 mbit/s down) when compared to two other speedtests executed over WiFi.

  • @Derek-Saville This is very promising. I've been holding onto 3.1.2 for a while now on the recommendations of users on this forum. Having a lot of IoT devices and Apple kit I need to make sure any update won't break thinks, it sounds like now may be the time to update to 3.4.3.

  • Hi @_apt - I would still hold on v3.1.2 unless you need to update for any other reason

    For people that are heavy Teleport users, an update to the Teleport App broke v3.1.2 forcing an update which I personally was not happy about, but none of the expat users I associate with have had any issues

    There were major changes to the code after v3.1.2 and the certified power levels for the channels, so it isn’t a surprise to see it break some installs - that is the nature of WiFi

    So make an informed choice, but the issues are not affecting everyone

  • @Derek-Saville The one issue with staying at 3.1.2 is that you are missing a number of security updates. If your Amplifi is behind a firewall that may not be an issue, but if it's the only hardware between you and the internet, you've got to review the CVEs involved and make an informed decision.

Log in to reply