AmpliFi HD Firmware v3.4.3

  • Hi @Matthew-Leeds - totally agree and maybe I didn't imply it enough with the "informed choice" comment

    I am not stating that users who upgrade may not run into issues - clearly it is happening and there is always risk

    But there are plenty of people who do upgrade without issue and don't belong to the community and/or post on here that everything went ok

    As a general rule I tell people if their internet service is currently meeting their needs, then I would resist updating unless there is compelling reason to do so, and CVE's are one of those reasons for some people

    I also tend to run units with most everything turned off and as manually configured as possible, noting the environment and what channels the AmpliFi is using before doing an upgrade (if in Auto mode) so you can directly replicate the same configuration as close as possible after an upgrade

    I also recommend using only standalone devices (no kits) and I don't follow AmpliFi's recommend procedure for updating all devices at the same time (never have actually)

    I take all units offline, reboot the main router only to 'reset' it, then upgrade the router only, testing it out to be sure the update is working as expected

    Then I update RAMP's one-by-one, and if there is a problem, it can be reset and updated manually then add it back to the mesh, although that hasn't happened except once a long time ago

    My Alien installations are all single unit router only sites, so I can't add to the meshed Alien conversations (wish I could join the fun, but I don't have a location that needs more than one Alien)

    The only issue I am seeing at the moment is Teleport specific to one particular ISP and their streaming app on iOS

    The update to iOS 14.x and the corresponding update to their streaming app causes the Teleport app to disconnect and router-to-router to pause, but no other streaming services are affected, so for now I have to assume it is the combination of things that will work itself out over time with further updates

  • @Derek-Saville So much if I had known, or were coming into this product at this point in time. I bought the kit with two MPs which has so far worked out for me. I recognize that should one die, no replacement is available aside from perhaps putting an Instant in its place. Amplifi is both ahead of and far behind its target market. The notion this is a consumer friendly product is a tough sell based on the traffic in the forums.

    It would be good to know what size the installed base is as it would provide some perspective against the perhaps dozens of folks who populate the support forums. I've stayed with 3.1.2 but then my unit lives behind a firewall/gateway. I've not had the issues that others have reported and so far the product has met my needs. I'm not running a high speed connect to my ISP, half of my devices are hardwired, and pretty much most of the WiFi devices are from a single manufacturer. I've some knowledge of networking and have managed to deal with minor issues mostly by depowering and repowering devices (old standby method, kick it in the head). I do plan to update the Amplifi devices soon now that Apple has addressed some of the possible issues in iOS. I've already gotten a download of 3.1.2 to downgrade back to if needed, and a third-party router in case stuff gets bricked.

    I agree, document what is before you change it. Document the steps you plan to take, then follow the plan. All this for a home setup.

  • Been running the new FW update since it was released. My setup is 4x RAMPs connected via ethernet backhaul servicing about 25 clients (33% wired and 67% wireless). No issues so far since the upgrade. Network connectivity appears to be stable with 2 people working remotely via separate VPNs alongside media streaming, etc.

  • @UI-AmpliFi There seems to be majority positive responses to this update reported , something not that common , one usually only gets to read about problem experienced.
    Now that the firmware is stable. Please add Homekit support.

  • Good afternoon.
    I just updated my AmplifiHD and first impressions are good, for example the latency between my PC and the AmplifiHD with version 3.4.2 was very unstable with latencies between 1 and 200ms, the 3.4.3 latency has become very very stable with sustained latencies of 2-3 ms and peaks of 20 ms. At the moment the new firmware works much better.

  • @buburcito How long time exactly was it since you updated to 3.4.3 ?

    Wait few days or a week and please report back about how it works both on wifi and ethernet speed.
    If it still has issue with wifi drop or ethernet drop speed,

  • I've been with it for about 2 hours, I can't tell you if the disconnections have been fixed because I've been with it for a short time, but the latencies have improved a lot, now it works as usual.

  • Hopefully ubiquiti will release a firmware that allows customizing the Amplifi HD screen, I see it very underused, it would be nice if you could put speed, time, date at the same time, replace numbers with bars, graphs, etc ...

  • Hi all,

    We have been running the new FW for one week now, and no problems or performance issues so far.

    We have a mixed environment:

    -IoT - Cameras, homekit sensors (all on 2,4Ghz) etc
    -Android devices
    -Three Apple TV:s
    -iPhones and iPads
    -One Macbook and one Mac Mini
    -Windows devices
    -Xbox 360

    We have around 20 devices connected to wifi and two wired, NAS and gaming PC. Backup is running from the NAS to cloud 24/7 (triggered).

    Connection is a direct fiber connection with 250/100 without any modem.

    We are three "heavy" users.

    -One teenager studying on University remote
    -My wife working remote as much as she can
    -Myself, IT - consultant, working remote to customers
    -A LOT of streaming

    So far I must say it work more than well - comparing with issues that has been in the past. I'm very happy with the performance and stability.

    I also manage two other systems for my relatives, no issue with those either.

    I wish you all a Happy Halloween!


  • @Mikael-Johansson I concur with Mr Johansson

  • I bit the bullet and updated from 3.1.2 to 3.4.3. Updated whet relatively smoothly, had to manually reboot device from app as was still showing 3.1.2 after update but when it eventually came back online all access points and connected devices working as expected. Will monitor and report back of issues occur.

  • I also did the upgrade directly from 3.1.2 to 3.4.3 about an hour ago. Went smooth as frosting. So far everything seems stable, all devices auto reconnected. Ran the WAN speed test and saw slightly better numbers, but given I was pretty much at the connection limit with my ISP anyway I didn't expect much there, just confirming no losses. I run a mix of wired and wireless devices so I'll report back in a week or so after I get some runtime on this.

  • @Samantha-Duthie Did you find the cause of your problem?

  • This update broke our hardwired xbox one online chat. Works fine when on Wi-Fi. When wired, they get the error "0x8923103D".

  • Temporarily turning off hardware NAT fixed the chat problem with the wired Xboxes. Of course, it also got terrible speed test results compared to it being on. Strangely, after each Xbox had an opportunity to operate with hardware NAT off, it would then work with hardware NAT enabled. But not unless it had operated with it off first. We actually had one Xbox One working with hardware NAT on, and the other one not. Once the 2nd one had run for even a short time with it hardware NAT off, it then worked with it on.

  • I spoke too soon. That appears to have been a temporary solution. Perhaps the Xbox One chat can only make the initial connection/handshaking when hardware NAT is turned off, but then will work when once the session is established.

    In any event, The 3.4.3 upgrade appears to have broken Xbox One online chat when hardware NAT is turned on.

  • @UI-AmpliFi I have upgraded to 3.4.3 from 3.4.3rc1 and it stopped my Sky Q system from working. The mini boxes were constantly producing errore that the could not connect to the router. This applied equally for the (3) mini boxes that are hard wired via ethernet and to the booster and mini box that connect wirelessly. I have rolled back to 3.4.3rc1 and all connecting again.

  • The upgrade to 3.4.3 from 3.4.1 killed my AmpliFi HD. Had to revert back to an Airport Extreme before leaving on a three week business trip.

  • @hensley1080p You are correct, my co-worker had same issue with update and had to roll back. Thought it was weird that chat worked on amplifi wifi but not wired connection.

  • @Matthew-Leeds OK, we've been on 3.4.3 for five days now. No issues, works just fine, like the new features in the web interface. I wonder if Amplifi has been correlating reported issues to hardware versions? Anyway our mix of devices don't seem to have noticed the update.

Log in to reply