"Multiple sessions detected" when trying to connect w/WPS


  • I am trying to connect a computer running Linux and the iwd connection manager. When I run "iwctl wcs wlan0 push-button" on the computer after enabling WPS on my Amplifi HD router, the iwctl command reports "Multiple sessions detected" and does not connect to the Wi-Fi. It was connected a week or so ago before I formatted the computer's hard drive and reinstalled the OS. My Amplifi HD router is running version 3.4.3 of the firmware, and the computer's Wi-Fi adapter is a Qualcomm Atheros QCA986x/988x using the ath10k_pci driver. The only two things I can figure are that either the Amplifi router hasn't forgotten that it issued credentials to the wireless card, or the wireless card has remembered it somehow. thoughts?


  • After examining the iwd debug log, I concluded that the problem was the fact that I have both the main Amplifi HD router and an Amplifi mesh extension unit, and iwd doesn't like the fact that both of them are willing to participate in the WPS pairing. When I unplugged the mesh extender and tried again, the WPS pairing was successful. I have sent a note about this to the iwd developers.


  • I heard back from one of the people involved in the iwd project, and he said that it appears that iwd is reacting correctly. It seems to me that about the only thing Amplifi can do to provide WPS on a mesh network is to restrict the WPS negotiation to the access point that detected the client station. Until that is done, the only way WPS will work with Amplifi's Wi-Fi mesh is to ensure that only one Amplifi access point can participate, either by unplugging the extension units or making sure only one access point is within range of the client station.


Log in to reply