iPhone 12 Pro never connects to wifi6


  • My iPhone 12 Pro is never connecting to the wifi6 radio or Alien does not recognize it is a wifi6 device. Logs sent.

    Update: If you go into the wifi settings on the iPhone and disable the default setting to use a "Private Address", then it rejoins the network and connects to wifi6. Bug maybe?


  • @Mike-P Here is a link to a 9to5 Mac article that gives some insight into the problem for both IOS and Android.
    https://9to5mac.com/2020/09/17/ios-14-privacy-cisco/


  • @James-Ford Thanks man. I wonder why randomizing the Mac would cause it not to use wifi6 though. By the way, I just came from Samsung S20 Ultra and I was using that feature, but the Alien still saw it as a wifi6 device.


  • I just activated my 12 Pro Max and it connected right away to my Alien on 5GHz band, I have them named separately, on the wifi 6 network. No issues so far.


  • @Mike-P so far as I can tell, the 9-to-5 Mac article doesn't address the issue of a device being able to connect as a WiFi-6 client. Also, I want to make certain I understand your message:

    When you say "randomizing the Mac" I assume you mean randomizing the Media Access Controller on an iPhone with a WiFi radio. Only the brand new M1 "Apple Silicon" Macintosh computers have WiFi 6 radios.


  • The 9-to-5 Mac article is referring to MDM systems, which use a device MAC address, as well as devices that are forced to use a security certificate by companies that allow employees to use their own devices. Neither of these things have anything at all to do with WiFi 6 network access.

    I just checked my iPhone 12 Pro and was not connected to my Alien on WiFi 6. I disabled the IP Privacy feature on my iPhone and checked again. I was then connected as a WiFi 6 device. So, I immediately enabled the IP Privacy feature again and reconnected. It is still showing as a WiFi 6 connected device and I have IP Privacy enabled. You may want to try simply disabling and enabling the feature on the phone and see if it helps.


  • @bshaheen but in the app is there the green wifi6 symbol or are you just connected to the 5ghz band?


  • @Mike-P My iPhone 12 Pro shows the green WiFi 6 icon next to it in the Amplifi devices screen:

    0_1605304129962_Screen Shot 2020-11-13 at 3.47.13 PM.png

    And here you can see that I have the Private Address feature enabled:

    0_1605304166823_Screen Shot 2020-11-13 at 3.44.21 PM.png


  • @bshaheen My settings are the same, private address on which it was by default - I never looked at it before - and WiFi 6 symbol next to my phone.


  • I am having this issue as well on the iPhone 12 Pro Max. I never had this issue with the iPhone 11 Pro Max so I am wondering if it is an issue with the Qualcomm radios?


  • @Jeff-Talento I also have the 12 Pro Max which replaced my 11 Pro Max. No issues with either one. So chips or radios shouldn’t be a factor.


Log in to reply