What IS the AmpliFi Alien capable of?


  • UK user here with a newly released Alien - the more I use it the more disappointed I am. 160MHz and WPA3 - is this router even technically capable of that? I skipped all other offerings to get the Alien and the speeds and range just don't seem to add up in multiple houses and with multiple configurations. I've tried to contact support who aren't the most helpful despite their positive intent. Returning the device seems to be an option if anyone in logistics can give more than a one word answer. So quite simply, is anyone having a flawless experience with the Alien? Will 160MHz and WPA3 ever come? My issues with dropouts and jitter especially whilst gaming (PS5 WiFi 6) and with online meetings are continuous and worse than my old ISP supplied ZTE router. I've changed channels, split devices based on 2.4GHz and 5GHz, created additional SSIDs etc. Any suggestions or updates? I'm tempted to return this and go with the Asus ROG Rapture GT-AXE11000 with WiFi 6e when it arrives next month, for pretty much the same price. What really differentiates the Alien? Any positive stories welcome! Thank you!


  • @Tahir-Merwanji I wonder the same. We’re a year in to this product life cycle and it hasn’t evolved at all. Maybe COVID is to blame - but I really hope it becomes the device we all bought into, soon.


  • @Tahir-Merwanji
    The funny thing is I came from the ROG GT-AX11000 (not 'e') to this Alien. The ROG had more customization but this had a cleaner interface and was more streamlined. This one actually seemed to be the more stable router although they both performed almost exactly the same.

    You can try returning it if you want if you want the other features but I think you'll find out the issues are just your ISP or other outside factors.


  • I honestly think its a Wi-Fi 6 issue. I came from the Netgear RAX120 and this router is SO MUCH more stable while the range and speeds might not be up to par. I haven't had any issues for the few months I had the router except since I got my PS5 (or maybe its related to the latest v3.4.3 firmware). The PS5 and randomly some other devices experiences weird disconnects when on the Wi-Fi 6 5Ghz band. Haven't noticed the issue on any other bands or frequencies. I had similar issues on the Netgear RAX120 but that was like daily with 2-3 devices. This is more once every week on 1 device at most.

    However compared to Netgear the support staff and the community (not us users but Amplifi employees are actively watching it) is un-comparable. The Netgear community has countless posts of users with serious issues (19+ pages on some, I was apart of a few) with no input from any Netgear staff. Also I was able to get to tier 3 tech support relatively easy with my Amplifi compared to them not even picking up the phone for Netgear and closing my issues before even talking to me.

    While the router might be lacking in some features the competitors have I rather take stability and strong customer support at this point over a bunch of features that barely work.


Log in to reply