Speed on cable.

  • Hello,

    I have tested my internet on my Gamers Edition.

    ISP gives me 1 Gbit/s.

    If i do a speed test on cable i dont get more then 500 Mbit/s
    I tested all ports directly in my Amplifi.

    i also turned on Hardware Nat, it keeps giving the same speed.

    My ISP tested my connection and thats ok.

    Does anybody have any idea's.


  • @CrazyDungeon Hi Crazy - I'm on Virgin Media 1Gb/s so will tell you what I saw.

    Enabling Latency Reduction halves the speed, so turn that off and try it out.

    I've only had mine since this morning so I can't speak more than that.



  • Hey Paul
    Just noticed this post and have spent 1 year in frustration with my ISP, the Amplifi router and the general performance of the internet in my house.

    The renewal date for Virgin Media was fast approaching and I started to do some analysis and talking to VM and Ubiquity support.

    First thing I learnt, the inbuilt speed test in the Amplifi app is not to be trusted, as you cannot choose the server and you don't know where the server is.

    Ubiquity's supports suggestion was to direct connect via ethernet a laptop and use Speedtest.net of the Okla Speedtest app. Having spent the last year very disappointed with 150-220Mbps (the reading from the Amplifi app, on a 350Mbps package, I ran the speedtest.net via the hardwired test, and bingo, the speed is where it should be. Run the speedtest on a number of servers nearby and also Virgin Media's servers.

    I did speak to VM support level 2 and they confirmed that running the speedtest.net app hardwired, would be best.

    I switch my Hub3 to modem only mode and then use the 1 ethernet port on the back (no others are active when in modem mode) to run an ethernet cable to the Amplifi router and then the mesh.

    I then did reposition the meshpoints to face the main router that seem to change the connection int he amplifi app from good to Perfect.

    Based on this I renewed with VM for another 18months and boosted the packed to 500Mbps (I can't get gigabit yet).

    Good luck, if you have not solved the problem try the above.

Log in to reply