Help Needed - Just Pulled my Alien Router and went back to my AMPLIFI HD


  • First this is my second Alien that has exhibited the same behavior...

    Internet Provider: Frontier FIOS (500/500)
    Firmware: Current

    I have been struggling with this and due to having to work from home finally just pulled my Alien router out of service. I need help.

    I am paying for 500MB up and Down. I previously had a AmplifiHD with Mesh points covering the house.. it worked fine. I moved to an Alien without the mesh point and the coverage was actually better.

    However my internet speeds seemed to be throttled to 100/100. I have played with every setting I can and nothing seems to fix this. I have factory reset the Router, and only configured the WiFi and DHCP for the Internet connection. Same results.

    I have plugged my laptop into the very same cable the router is using and I get my full speed. I have swapped my Alien for a BASIC AR750S router from GL.INet and it gets my full speeds. I can install my AMPLIFI HD and it gets my full speeds.

    I really want the Alien to work, but tireless trying it will not. I need help!


  • Hi @Dave-Martin - is the speed exactly 100 Mbps?

    That sounds like an Ethernet speed negotiation error or the web UI QoS Latency Optimization setting

    Have you tried different Ethernet cables?

    If you plug your Alien into the AmpliFi HD or AR750S and enable Bridge mode, do you obtain the expected 500/500 speeds?


  • @Derek-Saville almost always 95-98mb. I thought the same. Yes changed the cables. I have been unable to successfully set the alien to bridge mode and test connected to any of the other routers. Each time I try the alien router says there is no connection. Tried with both of the other routers and multiple cables. All other routers do run at 500/500 with same exact cabling.


  • Hi @Dave-Martin - sounds like a bad unit then and I would recommend an RMA or return it to the place of purchase if possible


Log in to reply