Will the Teleport connect to Amplifi behind double NAT?


  • I was wondering what technology the Teleport uses to establish the connection back to the AmpliFi? Can it connect if the AmpliFi does not have a public IP assigned to it but is behind NAT or even double NAT?

    Stephen


  • @stephen-h Hi Stephen. The underlying tech is subject to change, but it either has this ability now (if you have UPnP) or will have it soon (by using other techniques).


  • I have not gotten Amplifi HD-Teleport to,pair successfully behind a UniFi USG router (double NAT). Amplifi support tells me that Amplifi is designed to have a public ip address as is Teleport (separate of course).


  • @g-r-martinez That's bad news. I also have a UniFi USG and my Teleport is on the way. I found I needed the USG because the unstealthed firewall on the AmpliFi was leading to random DoS from people looking for open ports.


  • @g-r-martinez, @Chris-Shouts: Hi! If the USG (or any other router upstream of Teleport's router) has access to a public IP address and is running UPnP services, it will still work. For USG UPnP is off by default, if I recall correctly. And only newer versions of the controller support enabling it. Also, we'll be removing the UPnP requirement later on.


  • I have a USG and got this working. It certainly is NOT an intuitive product, Issues:

    • need to put amplif HD in bridge mode, note enable upnp on the amplifi before you do this (not sure it makes difference but support will ask for you to have done that)

    • then i suggest using a PC to complete the teleport setup via the https://teleport.lan address in the next few steps

    • when establishing the teleport you must not join it to your unifi OR amplifi network, the first config page is the name you want to call your teleport access point (like mynameteleport).

    • in the next step when you want to join it to a network i suggest you join it a mobile hotspot like a cell phone (joining it to you unif or amplifi SSID just wont work)

    • as it is finalizing the steps you will need to pair with the amplifi, this will require the amplifi app, i reccomend using another ios or android device to do this as it seems to be funky if you do it on the device that is acting as the hotspot

    • once this is done you can verify if it is working from the client devices, they will have an IP address from your home LAN, full network discovery will work from a PC, it is pretty awesome

    • issue: once the teleport is connected to a network there is no way to get to https://teleport.lan unless the teleport is disconnected from the hotspot. This is easy to do if it is you cell phone, you can turn the hotspot off. If you are on a hotel or conferenc network this is not so easy. This IMO is the number one bug that needs adressing.

    If you are on the ubnt forums and need help look me up.
    Alex Balcanquall


  • @UBNT-Gunars is there anyway for me to take the amplifi HD out of the equation and just use the teleport directly with my unifi network. More for interest and less moving parts, i actually think the amplifi HD is gorgeous piece of kit, but with 13 unifi devices on my network i will never use it for anything other that the teleport....


  • @alex-balcanquall Hi Alex! Teleport only supports AmpliFi for the time being.


  • @alex-balcanquall said in Will the Teleport connect to Amplifi behind double NAT?:

    issue: once the teleport is connected to a network there is no way to get to https://teleport.lan unless the teleport is disconnected from the hotspot. This is easy to do if it is you cell phone, you can turn the hotspot off. If you are on a hotel or conferenc network this is not so easy. This IMO is the number one bug that needs adressing.

    Hi! http://teleport.lan has been completely removed from teleport. You should use http://amplifi.lan to access both devices. There is no need to disconnect the teleport to do so.


  • @ubnt-gunars said in Will the Teleport connect to Amplifi behind double NAT?:

    @alex-balcanquall said in Will the Teleport connect to Amplifi behind double NAT?:

    issue: once the teleport is connected to a network there is no way to get to https://teleport.lan unless the teleport is disconnected from the hotspot. This is easy to do if it is you cell phone, you can turn the hotspot off. If you are on a hotel or conferenc network this is not so easy. This IMO is the number one bug that needs adressing.

    Hi! http://teleport.lan has been completely removed from teleport. You should use http://amplifi.lan to access both devices. There is no need to disconnect the teleport to do so.

    @UBNT-Gunars Thanks, understand about only working with amplifi 🙂

    the http://amplifi.lan was absolutely NOT accessible to either the PC or the IPAD when the teleport was connected to a hot spot. I had to turn off the hot spot (at sarahs suggestion from support) this caused the teleport SSID to disappear for about 2 mins, once it came back i was able to connect to teleport.lan (which is what support told me to connect to. Happy to test again... off i go...


  • i tested, same, my laptop is connected as follows

    laptop > teleport > mobile phone hotspot > internet > USG via the upnp port open > amplifHD

    i can access my entire home network (feaking awesome even network discovery works!!!!)

    i can't access http://amplifi.lan

    (oddly every time i connect with teleport the amplif says there is a firmware 2.5.4 on its LCD, when i disconnect the teleport the message dissapears!?)


  • @alex-balcanquall Looks like it wants to update teleport to the latest version.


  • @ubnt-gunars said in Will the Teleport connect to Amplifi behind double NAT?:

    @alex-balcanquall Looks like it wants to update teleport to the latest version.

    I did that, doesn't seem to have fixed the inability to acess http://amplifi.lan

    Is that name using mDNS resolution or some other way to get to the page? I ask because once connected the client machine is calling my DNS servers which has no name registered, none of my mDNS clients can access amplifi.lan either, also there appears to be no listener on port 80 or 443 of the teleport device...?


  • @alex-balcanquall Can you take a look at this, @UBNT-Karlis?


  • When AmpliFi router is put in bridge mode then it is no longer DNS server for connected stations. Stations then receive new DNS server address from your UniFi USG. I think that normally UniFi USG is DNS server for LAN devices.

    The solution would be to create a static lease for AmpliFi router and then create a DNS secord for amplifi.lan on your UniFi USG.

    You can also access AmpliFi router Web UI by opening http://ip-address in web browser. IP address of router is displayed on LCD on "DEVICE IP" screen.


  • @ubnt-karlis said in Will the Teleport connect to Amplifi behind double NAT?:

    When AmpliFi router is put in bridge mode then it is no longer DNS server for connected stations. Stations then receive new DNS server address from your UniFi USG. I think that normally UniFi USG is DNS server for LAN devices.

    The solution would be to create a static lease for AmpliFi router and then create a DNS secord for amplifi.lan on your UniFi USG.

    You can also access AmpliFi router Web UI by opening http://ip-address in web browser. IP address of router is displayed on LCD on "DEVICE IP" screen.

    Yes that’s what I figured, I already had tried the http://ipadddr method to the IP address before I ever posted, that didn’t work either, but I will verify tomorrow. Have you thought about allowing the teleport respond via mDNS? I.e. on amplifi.local ?


  • @UBNT-Karlis

    Hmm i tried this multiple times yesterday and i swear i couldn't manually http://ipaddr
    on testing now i see i can use either the ipaddress of the router or the teleport. I suspect i had some other issue...

    could you consider letting use set a custom name too, so for example if i create a dns entry for amplifi.mydomain.tld i could use that? (for now i created a .lan zone and a host record for amplifi.lan on my dns server pointing to my now statically addressed amplif router)


  • Thank your for the feedback, it is much appreciated!

    Please post your feature requests at the link bellow, so the others could find them and cast their vote.
    https://community.amplifi.com/topic/316/call-for-feature-requests-1


  • Easy to setup?!!! .... are you kidding me. I would not recommend this device to any of my clients... I already wasted over 2 hours and keeps failing at step 7 to 10 to connect to the Amplifi. Now I have to go thru Alex Balcanquall approach to use the phone as a hotspot and use another phone for the Amplifi, and I have to leave the country in 6-7 hours. You guys are nuts. I'm a technician by trade and what is required to make this work is crazy. Waste of money and time.

    Tried using mobile hotspot - no go ... tried Amplifi in Bridge Mode no go ... I give up ... my time is more valuable ... hope I can send it back ... for Alpha testing maybe, for sure is far from prime time.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.