BT FTTP AmpliFi Alien


  • I'm thinking of buying an Alien - has anyone connected to BT FTTP and if so, did you have any problems?


  • @55Fisher No problem connecting to BT fibre broadband as long as you have the modem to connect to.


  • @Ali-Hadi I have the BT hardware in the cupboard yes. Presumably I can do away with the BT router and replace it with this as I’m connecting directly to the BT modem which had the fibre cable terminating in it? Just assume no need for any other modem as I understand the Alien is a router only?


  • @55Fisher Correct. You will need your BT broadband's username and password to connect to the alien using PPPoE mode.


  • @Ali-Hadi Great - thank you. Have you used the Alien? Would you recommend?


  • @55Fisher You are welcome. Yes, I am using the Alien as it is such a solid router with a decent WiFi reach. I am, however, using it as an access point in bridge mode as some of the advanced routing features that I use are unfortunately not available on the AmpliFi. Only a couple of small niggles in that it's WiFi reach has been a bit shorter than its predecessor the AmpliFi HD kit but it's not far off and the AmpliFi has had the 2 additional mesh points to be fair. I was also a bit disappointed that the EU version is dual band unlike its US counterpart and therefore may be a bit less future proof. Otherwise a solid performer and easy plug and play and then forget for it to just do its job.


  • @Ali-Hadi said in BT FTTP AmpliFi Alien:

    No problem connecting to BT fibre broadband

    I'm sorry. I don't know what "BT FTTP" is. I'm assuming it's an abbreviation for a specific ISP. Is that correct (and that FTTP may abbreviate "fiber to the premises" or something similar.

    Thanks so much.


  • I got my Alien today and connected it to Openreach modem. I also have FTTP from BT broadband. I am on 900 download and 110 upload speeds when I use ISP's router (BTHub)
    My PC is connected with ethernet cable and almost always gets close to 900 download speeds and 100 upload speeds on speedtest.net on my old BTHub. When I connect today my new Alien I used PPPoE when setting up and typed credentials found online ( username bthomehub@btbroadband.com and password BT)
    Alien recognised credentials and was up and running in few minutes. The problem is my speeds are limited now to 100/100 no matter if I test it on Alien app, WiFi device or wired PC or Alien router itself.
    Is it ISP fault, Alien router fault my setup fault or something else ?
    Any help would be much appreciated


  • @ultrajapa Assuming that you have updated to the latest firmware, tried a different ethernet cable and a different speed testing tool (especially one other than the built-in speed test) and also attempted a factory reset of your device, I would think that it could be a faulty router and would start looking for a replacement perhaps. Your setting process appears to be completely correct.


  • Hi @ultrajapa - if your speeds are exactly 100/100 then it sounds like an Ethernet speed cable negotiation problem

    Create a Support Info file and submit a bug report and they can check

    Also make sure that the Latency QoS option hasn’t been enabled in the web UI


  • Thanks to both Ali and Derek. I didn't think of changing a cable because my old one was doing fine and was giving 900/110 speed test results regularly on my old BTHub

    I just tried a different cable and it works like it should now with Alien.

    Thanks both of you for this suggestion.
    Problem sorted on the same day it got posted.


Log in to reply