Issues with Mesh


  • I seem to be finding a lot of people having to RMA their Aliens mesh systems due to them having issues.

    I am now RMAing mine as it will no longer connect to the router unless it's less than 2 1 feet away from it.

    Is this a widespread issue??


  • With the latest 3.5.1 firmware update, I am now having this issue where the router mesh does not connect unless it is 1 foot away from router.

    Why can't they get this right? It seems this is a recurring issue with them and their firmware updates.

    Any help on this would be appreciated as I have had my Alien Router Kit with Extra Alien Router connected for 9 months working great until this last update.... then it all broke.


  • @Kimo4Texas I RMAd my mesh setup and got a new one composed of two routers.

    However now I am having some devices (only a few) where all of a sudden I keep getting prompted the WiFi password again and again. I honestly though about reselling the new ones I got from the RMA and going with a new setup due to all the random issues and I didn’t. Somewhat regretting that. I had a R7000 before that lasted me 5 years without a single issue. It actually still works and is my backup but I wanted WiFi 6.


  • Thanks for responding Pedro:

    I just completed my RMA form to return the Alien Router Mesh Kit, and just keep the one Alien Router...for now.... I hear you on the Wifi 6 I thought this would last me years also, but 9 months and returning also....so sad.

    I think for this kind of money they should have better support and better firmware updates with regression testing to make sure it all works as expected for the numerous scenarios/configs. I agree with you. I think I should probably RMA my other Alien Router also. Just too many issues for such an expensive device.


Log in to reply