Roku Premiere will not connect to 2.4


  • I just replaced a Nighthawk setup with a two tower Alien system (ethernet backbone). All worked very well, except that for some reason, my two Roku Premiere units will NOT connect to the network. What it looks like is:

    • On the Roku, I see the "connecting to wireless"
    • On the Alien, I can see an IP get provisioned and setup
    • The Roku then says it can't connect to the internet
    • The Alien no longer sees that IP connected.

    I have no other problems with any other 2.4 devices, nor any other Roku's connected to 5 MHz. Just these two devices which worked perfectly with the Nighthawk and do not like the Alien whatsoever.

    Anyone run into this before?


  • Hi @rickeames - for diagnostics, have you tried disabling the Common SSID to see if Roku clients can then connect to an 'uncommon' separated 2.4 GHz SSID?

    Or you can also try creating a unique 2.4 GHz specific Additional SSID independently for them to attached
    (note that these are created per mesh point, so typically the closest one to the clients)

    https://help.amplifi.com/hc/en-us/articles/360010201854-Configuring-SSIDs

    Otherwise it helps to create a Support Info file just after the failed connection attempts and submit a Support Request...
    https://help.amplifi.com/hc/en-us/requests/new?ticket_form_id=722908


  • @Derek-Saville I’ll give that a try. I was reluctant to go that route because I have a ton of IoT devices that will freak out, but it’s worth a shot. The problem isn’t that it can’t see the wireless, it’s that after it gets assigned an ip, it just won’t connect to the internet. From searching Roku forums, some have had to turn off legacy 802.11b rates, but I don’t know if that’s different from the nighthawk.


  • Hi @rickeames - due to your IoT devices you might want to just try the Additional SSID option using only 2.4 GHz and provide a dedicated SSID for the Roku

    If both Roku's are going to connect to just one of the Aliens, then you only need to create the Additional SSID on the access point they will be connecting to, which may be the Alien MeshPoint and not the main Alien router, so be sure to select the proper one in the app (Additional SSID's are not meshed by default)

    Are there any firmware updates available for the problematic Roku clients?

    Are the problematic Roku clients capable of connecting to a 5 GHz SSID, they just can't seem to get a good 5 GHz signal?

    If you temporarily move a problematic Roku to a location where a good Roku can connect at 5 GHz does it then work?

    Do you have a US model Alien?

    If the issue is a week or noisy 5 GHz signal and you have a US model Alien, one other potential test is to enable the Additional 5 GHz Radio option with a unique SSID and see the problematic Roku clients can connect to it instead

    The Additional 5 GHz Radio utilizes a different channel from the main SSID and may perform better for those clients

    And if any of the above doesn't fix the problem there are some other things to try, but it is still best to also generate a Support Info file after failed connections and submit a Support Request for them to analyze the data


Log in to reply