AmpliFi HD Firmware v3.4.4

  • @Matthew-Leeds you won’t ever get detailed info on firmware updates. Never have never will. Amplfi does what it wants and never listens to its customers. Example been asking for ability to remove old devices and development won’t address it. Only way to cleanup old devices is a factory reset and start over. It’s crazy! There’s more history and won’t get thumb cramps with many other examples. I like the technology but development is way slow, not documented and not consumer friendly.

  • @Rich-Sammon Negative responses won’t help anyone, in my opinion. I think they do their utmost best to deliver solid firmware. Nevertheless, there will always be setups and environments where there are problems. Reporting them will eventually result in a more stable firmware, from which we all will benefit.

    But I do agree that more extensive release notes would be much appreciated and valuable. @UI-AmpliFi Is this something which can be delivered with future releases?

    Version 3.4.4 looks promising based on the feedback so far. I’m on 3.4.3 since it was released and no issues whatsoever but will wait a few days before upgrading.

  • No issues at all for me after running it for three days so far. Everything has been rock solid.

  • @John-Meinen-0 I disagree. When you pay $1,500 for a home network ( yes I did) that is unstable when you see something say something...I don’t hand out lollipops or ribbons for trying. There is no place to give feedback (forums are never read by development) for consumer surveys (a thumbs up or down IS NOT A SURVEY) to give real feedback to make the user experience better!....give your experience a few years when you constantly have to down level and factory reset your entire network several times a year to make it work reliably with a household of 4 that need it to for their jobs and you will start saying these experiences. I like the technology a lot but there are basic admin features this product desperately needs and many of us have asked for it for more than 3yrs and it never ever never ever happens! Look at the firmware updates that come out with absolutely no technical detail. I was unable to use v3.4.3 which I tried and spent hours several times and had to drop down to 3.1.2 which has been reliable thus far. I’m happy to give kudos when deserved but ANY TIME you touch AMPLIFI devices it’s like a Forrest Gump box of chocolates you never know what your gonna get! 🙂

  • I was on 3.4.4 rc3, no issues. I upgraded to 3.4.4. and still no issues. Seem a good solid update

  • @Rich-Sammon

    With you on this.

    I updated the firmware yesterday on my Amplifi unit, which I have had for 2 years now with no issues.

    In the last 24 hours my speeds have drastically tanked, I spent an hour today trying to connect a PC that has had no problems connecting previously, and have been generally frustrated. I almost bought a different unit today.

    If I'm shelling out hundreds of dollars on a unit, I expect that unit to perform consistently. There's no participation awards.

    I'm an IT professional at the senior level, and I use ubiquiti appliances at home because I advocate for them in the field. I put my money where my mouth is, I made a full switch from CISCO, and ensure I know my products inside and out.

    I'm disappointed in this update. I was hoping for more advanced features. Instead I got frustration and headaches.

  • @Edward-Stanaway sorry to hear that but as a tech person as well this network technology should work reliably even when updating. So give this a try unless there’s a tech reason you need it. Turn OFF the NAT and turn on IPv6. Sometimes turning off the UPNP improves things...if not change keep it on. You can try mr. reboot entire system and if all these don’t work the help agent will suggest a total factory reset before you down level. That’s my point...nothing but a box of chocolates....can we send our hours of labor bill to Ubiquiti so they can see how many hours of troubleshoot unhappiness we spend for the money we spent upfront.🤔

  • @Rich-Sammon I agree that it should work that way but with every environment being different there is no way every environment is going to work the same way. This is one person that has had this problem and I am sorry to hear he is having the problem. My final decision will be made after watching problem reports once the update has been out for a few weeks. I am still sitting on 3.1.2 because the number of problems reported by other updates was too many for me to take a chance on updating. I hope whoever has problems can find a solution and remembers to report the solution here.

  • @James-Ford i agree which is also why i am still on 3.1.2 which i did two months and was sitting on v2.6.3 for 2+years. Don't mis-read what i am saying as I'm being openly vocal with these problems so I am just not on the page with you or others who don't see/feel what i experience. You are supplying an "public excuse/exemption" to the technology provider that every environment is different. The problems are self-induced by the product, not the environment. Buy any other router out there and the stuff just works and gives you admin functions to control the environment...even updates to firmware are easy although most providers don't let you roll-back so that is why i like some of amplifi. If it wasn't for the mesh capability for my entire home I would NOT be using this product at all. I'm not letting Ubitquiti off the hook...yes, it is a hook. I'm spending/wasting my time typing in this forum for a reason...I want it to work and for the product to give us basic functions to live a happy digital/IT/internet life...that's not what amplifi is's partial...i want the full happy experience for the money I spent.

  • Buy any other router out there and the stuff just works...

    Thank you, I haven't laughed so hard at a post in quite a long time...

    That’s my point...nothing but a box of chocolates...

    Mass production boxed chocolate is uniform and quality controlled, so to anecdotally attempt to imply "randomness" in the DPO is pointless

    Has AmpliFi released firmware with show-stopping bugs? Yes, on a few occasions, and they have responded pretty quickly to fixing them, and they eventually implemented the staged rollout to help mitigate such occurances

    Has AmpliFi rushed firmware releases? Yes, they have on occasion to address CVE's that are published without going through a longer beta period, but that is not the case for v3.4.4

    The first public beta for v3.4.4, which was actually rc2 and not even rc1, appeared just a couple of days after the SSID issue...probably not a coincidence

    And then it stayed in beta for almost a month with an rc3 release as well, so unless you have an urgent need, there seems to be no compelling reason to upgrade

    My HD's were all relegated to being Teleport servers, 3rd party mode extenders for Aliens, and Teleported gateways (router-to-router) behind Aliens, so I don't personally use them as a router anymore, but I still advise a lot of people that do and of the 20+ upgrades to v3.4.4 that I know of so far, there have been zero complaints or issues reported

    I see far more issues created by client updates (i.e. iOS), app updates, ISP updates to leased hardware, and environment changes on both the LAN side and the ISP infrastructure on the WAN side than I ever have from AmpliFi firmware

    Have there been AmpliFi issues that drove me crazy? Absolutely, the MAC bug did, and many things have remained broken for a long time, but they are also fairly easy to work around as well

  • My nest learning thermostat will no longer connect to the network after this update. Anyone facing a similar problem? My setup is two AmplifiHD in wired backhaul

  • @jaja-eeh Happening here, Wifi bandwidth drops to < 10 MB/s now and then, sometimes getting better later, sometimes a restart is needed.
    Even after restarting the device, the bandwidth is pretty low and gets better during the next minutes.

  • @Ramkumar-Natarajan sorry to hear about the issue...try turning OFF/ON one at a time the NAT or UPNP feature see if that changes. also turn OFF/ON the backhaul as well...otherwise do the reboot once/twice in sequence...Main router, 2nd Router, antennas...last resort drop down to your last firmware level when it was working...are we having FUN yet community!...the box of chocolates taste good as we waste our time troubleshooting...should a thermostat device that runs on 2.4ghz signal have these kinds of problems...sorry i'm being sarcastic to those that seems to feel amplifi is such a simple product to run/maintain...Have a Great Day! :))

  • Just for perspective I'll point out that the vast majority of owners of a product from Amplifi have never logged into these forums. Generally folks seek out such forums when they have issues, so we have a skewed population.

  • I used HD Firmware v3.4.3 for 58 days without any issues and without the need for a restart. I installed v3.4.4 on Feb 11 and had slowdowns which required a restart twice within a 6 day period. I rolled back to 3.4.3 today and I'll see if any problems arise.

  • I just updated to 3.4.4 from 3.4.3, in the hopes of trying the “forbid fingerprinting” and “forbid igmp proxy” settings that were documented during the beta. I think one or other of these might stop an HD router from broadcasting mDNS requests to every device on my network every minute. But the options aren’t there! Were they only there during the beta cycle? Surely there must be a way to set those options...

  • Just to be sure: you tried the web interface? Those options are only to be found in the web interface, not in the app.

    Someone correct me if I'm wrong.

  • @Pitch4Life-Rich-S I switched the Nest to guest network and then back and that seems to have fixed the problem. I hear you though - I love my Amplifi setup - so much so when one of my HDs failed last year I replaced it with an identical one even though in 15+ years this is the first router that I faced hardware failure. I wish Amplifi gives an option to not have updates if your setup is working well or turn off the touchscreen - I was sticking with 3.1.2 or some 3.1.x version that was good for my setup for almost a year and my kid accidentally hit the touchscreen last week triggering the update.

  • @jaja-eeh Yes. After several reboots and ping tests and speed tests, validating my ISP was fine I just reverted back to 3.4.3. Seems to have fixed our intermittent slowness issues.

  • @Wouter-van-Nispen-tot-Sevenaer yes, that’s right, but the options are not there on the web interface. From previous screenshots I’ve seen, they were under a Diagnostics section, which isn’t there on the final release.

Log in to reply