AmpliFi HD Firmware v3.4.4

  • @Ramkumar-Natarajan i agree 100%. Wife hit the update by mistake while cleaning once.

  • @sddawson these always been under beta options and the beta options are only visible if you enabled “Receive beta firmware”. They still visible for release versions though so you don’t have to install beta versions

  • 3.4.3 was the first bad firmware in more than a year for me with 5GHz band often dying on mesh points. 3.4.4 was solid since the first beta

  • @Timofey-K Yes, I just had this confirmed by Amplifi support. Maybe it would be better to always have these options under some sort of “Advanced” or “Experimental” section, since they’re not really beta options as such. Oh well, at least I can try them! Thanks for the input...

  • OK, just updated to 3.4.4. Took longer than I recall updates to take, but everything seems to have come up clean. Speed test to ISP had same result as before. We'll see how it goes.

  • 3 x HD's ethernet backbone. 2x meshpoints. Upgraded to 3.4.4. No issues. Unlike many others, this setup has been rock solid on every firmware so far to date - but - at this location I only have a 20/3 connection so nothing is pushed. There is almost no external WiFi to contend with due to remote location. There is an exterior airMax LiteBeam AC using 5G to a remote location but that does not seem to interfere at all with the interior 5G WiFi. Job well done UI team.

  • Whatever happened to 802.11r support? Has it ever been added back as an option in web gui?

  • I need the AmpliFi return the Enable switch buffer workaround option, which was removed in version 3.3.0. Due to the fact that this function is firmly enabled, the upload speed drops to 30-60 Mbps (I have a 90/90 Mbps PPPoE connection). I'm communicating with AmliFi support, so I'll see how it turns out. That's why I switched to version 3.1.2.
    I tried 3.4.3. and 3.4.4. and on both versions the upload speed gets angry. In addition, the router is warmer than at 3.1.2.

  • @UI-AmpliFi anyone else getting Homekit devices dropping off constantly? Worse I’ve had so far.

Log in to reply