Meshpoint stopped working - no power


  • Hi, my mesh point has simply stopped working. It has been plugged in, lights on and working fine and nothing had changed until suddenly today there were no lights on the ‘wand’ and my app says the mesh point is offline. The power is still switched on at the plug and my other mesh point and router is working fine.

    Please advise/help?
    Thanks


  • Hi @popey - you can swap the plugs between the working and non-working MeshPoints to see if it is the power supply that went out

    They separate at the magnetic ball joint and are interchangeable


  • @Derek-Saville I have swapped the wand with the other base and it works (has power) so it’s obviously the plug that has died. I have had the unit for less than a year?! What do you advise?
    Thanks


  • Hi @popey - I would suggest filing an RMA
    https://rma.ui.com/

    But note that because it is a kit with the mesh points hard coded to the router you would need to return the entire system for replacement

    Support might offer to replace just the power supplies, but I am not sure of their policy

    If you purchased with a credit card you can also check if your card has a one year warranty and file a claim with them


  • @Derek-Saville thanks. To be clear, Are you Ubiquity customer services or a helpful community member? Surely I can get a replacement plug or mesh point rather than send my whole system back?
    If you are not customer support do you have a contact email for them please?
    Thanks


  • HI @popey - I am just a community member... @UI-AmpliFi is the Ubiquiti presence here

    You can find some warranty information here:
    https://help.amplifi.com/hc/en-us/articles/115007243367-AmpliFi-Returns-Replacements-and-Warranty

    Otherwise you can find a live chat link on https://help.amplifi.com/ or email them at help@amplifi.com

    FYI - it is not possible to replace the mesh point of a kit without replacing the entire system as they are hardcoded together and cannot be separated or reused

    Hopefully they will just send you a replacement power supply


  • @Derek-Saville many thanks, really appreciate the help


  • I have spent the last six months trying to get this company to understand this issue re: the Ampifi Meshpoint power supply just suddenly dying. (It's not like it's a new issue; multiple citations on the internet.) Their customer service sucks (email only); they reply as if they have very little knowledge of their own products; they can't possibly be reading the entire emails I send because their response regurgitates steps already taken and documented in my emails, etc. And the RMA site is worthless (see below). IF you decide to pursue, good luck as it's my belief they could care less about hearing let alone resolving a defective device issue.

    Great product when it works; ABSOLUTELY THE WORST CUSTOMER SERVICE I HAVE EVER EXPERIENCED IN MY ENTIRE LIFETIME.

    To put the email below in context, this is probably the 12th-15th email exchange with the company. I normally don't use CAPS in my emails or snarky generalized statements but unfortunately I am at my wits end with these people.

    Feb 22, 2022, 17:57 MST

    I'm sorry, but WHAT DO YOU NOT UNDERSTAND?

    How many times do I need to write to this company supposed customer "help" email address that I am unable to use rma.ui.com because that WEBSITE IS TOTALLY USELESS!

    Let me illustrate:

    I have attached photos of the actual AMPFLI Meshpoint HD unit that I purchased for which the AC power supply is not working.

    As was suggested in August, and again in emails from the past 2 days, I went to rma.ui.com

    I am asked to put in the MAC ID or Serial # under either Device or Accessory

    I look at the back of the AC power supply. The number listed is 18410046, so I input it under the Device tab; note that it is short 2 digits based on the character blocks presented.

    I immediately get We don't recognize that MAC ID. Make sure you're entering the number highlighted to the right and try again.

    So, I try it with 2 zeros at the end; same result; try it again with 2 zeros at the front; same result

    ​Next I try the inputting the 18410046 under the Accessory tab.
    I select search; the spinning circle comes up and continues to spin for several minutes.
    I finally stop it.

    So next, I figure I'll try inputting the other two numbers listed on the other piece of the device. First I try 1848G B4FBE4938BAD, with and without a space between under the Device tab; Surprise! I immediately get: We don't recognize that MAC ID. Make sure you're entering the number highlighted to the right and try again. I next try the other number 1848G B4FE49384FF. Guess what? Same message.

    So, I think, well, perhaps it's just the last set of characters instead of all. (No guidance anywhere on what is the MACid vs. the Serial #). So, i input B4FBE4938BAD under the Device Tab; I select search; the spinning circle comes up and continues to spin for several minutes. I finally stop it. I also try B4FE49384FF. Same result.

    Next, I try the same steps using what appears to be the serial # as stated above under the Accessory tab. For both numbers. Same results.

    So, now I select: I am unable to find a MAC ID / Serial Number
    This brings me to a pop-up box which after telling me where to look for the MAC ID / Serial # (Nothing new here) has the following text: If you still can't find the MAC ID or serial number, click here.

    So I click here, which brings me to yet another pop-up box. If you don’t know your product’s SKU, click here.

    So, I click here, which brings me to https://www.ui.com/products/#default

    Products - Ubiquiti
    www.ui.com
    I look for my product Amplifi Meshpoint HD, which I find, click on and it brings me to another page https://store.amplifi.com/products/amplifi-meshpoint-hd

    which NOWHERE is there an SKU number listed. Nice.

    So, I go back to the last pop-up box and use the Search feature line. It tells me I can search by product name. Great! So, I type in AmpliFi and before I can finish, it tells me So, I type in AmpliFi and before I can finish, it tells me No Results Found. I type in Meshpoint and before I can finish, it tells again, No Results Found. Ditto when I type in 1846G; or 802.11 (which was the beginning of another description listed on the product page)​

    So, at this point I have NO FURTHER OPTIONS anywhere on the rma.ui.com website. And despite listing a 24/7 chat function on your contact page, there is NO LINK! Just this email address is active. Thus the multiple emails over the past 6 months.

    NOW DO YOU UNDERSTAND WHY I AM SO FREAKING FRUSTRATED WITH THIS COMPANY?

    I have probably spent at least 4 hours or more on this issue since last August. Please help to resolve this issue asap. If this needs escalation to a supervisor, manager, whatever please do so.

    Thank you.


  • @Derek-Saville They will not honor it under warranty. The power supply is not sold separately. And the product is listed as unavailable on their website (although still available at other retailers). Perhaps they are discontinuing. See my post from 2/23/22


  • @kvanczd Thank you for your patience. We've escalated your case to a manager to make this right as soon as possible!


Log in to reply