What is the RMA/Warranty Process Like?


  • Hey,

    What's the process with RMA/Warranty work? I've been issued a warranty service for my Amplifi Alien, but I've been left pretty much in the dark on how it'll work. Will this be an uphill battle in trying to "prove" to Amplifi that my device seems to be faulty? Do they contact you to discuss? And how long do you generally sit with out a router - 1-2 months?

    The Amplifi Alien router that has been an absolute dream and my favorite router of all time up until three weeks ago when I upgraded from 3.4.0 to 3.4.3. Since then WiFi and LAN connections will drop all at once, and the only way to gain connection back is a doing a power cycle. That power cycle, will then freeze the unit at 99% and then require another power cycle.

    Customer Service recommended I turn off beam steering and auto channel to see if that would rectify the issue, though I don't have a lot of connections by me with in 50 feet so interference is pretty minimal. Customer service then recommended I jump to beta 3.5.0 but on the software install I immediately had another 99% freeze. After rebooting, it worked but with in one hour the device stopped all connections once again. In total over 2 weeks I've had 9 crashes - 7 on 3.4.3 and 2 on 3.5.0.

    What makes me nervous is that while 3.5.0 has been less than ideal and no way close to as solid as 3.4.0, It's "only crashed" twice over the span of a week. So now I'm wondering if Amplifi will try and give me a hard time since it's "functioning" (in the loosest sense).

    The customer service process has been less than ideal though with trying to work from home and still have internet while getting a response will take a minimum of 24 hours by email and the RMA process taking 48 hours per email. I didn't even get the shipping label when I was accepted for the RMA process.

    Thanks for any guidance!


  • @tylerpoppe Update?

    Thanks


  • @microkraken hey, all went well. While I feel I was pretty in the dark in the process, they sent me a new one wrapped in plastic brand new, I sent the old one in my old box and the shipping box they sent and that was all she wrote.


  • Thanks for the update. Much appreciated.


  • FWIW, I started my RMA (non-functional router LCD) back on Mar 6th. Had to resubmit on the 10th because I put in the MeshPoint MAC address instead of the router's. RMA was approved on the 11th. The replacement was shipped on the 17th and delivered on the 19th.


  • @r8ders2k I

    Im having the exact same problem. Can you tell me how you contracted them to start the RMA process

    Thanks
    Frankie


Log in to reply