Need help to optimise mesh system


  • Hi

    I have a Ubiquity Amplifi mesh system constisting of a router and two mesh points. I have FTTP Fibre Internet 76 Mbps download and 20 Mbps upload.

    The router is located in a bedroom on the first floor a shelf above the door. One of the mesh points is in a bedroom adjacent to that with the router, same floor. The other mesh point is downstairs in the entrance / lobby area, inside a storage compartment underneath the stairs.

    Iniitally I was planning on putting the mesh points like one in the living room and one the kitchen on the ground floor (router is upstairs), but the App was saying they were too far away so had to relocate them to where they are at the moment.

    My problem : I cannot get closer to the expected 76 Mbps download speeds when over WiFi from either mesh point, which is around 42 Mbps, even if a feet away. If I stayed in the same room where the router were then the download speed is as expected. I also ran a test through the router and I am certainly getting the speeds as expected from the ISP.

    I will be truly grateful if somebody can take a look into this with me. This is a product advertised to cover an house of 20,000 sqft. Mine is 1,100 sqft and I am getting ca. 58% of the Internet speed over the mesh points, and I wonder whether this is actually good enough.


  • Is the reason that nobody is picking on this that the router and mesh points are a black box which you can't tune and adjust to work better?
    My previous setup was a ASUS RT-AC86U and Netgear mesh extender EX8000. This system was able to give me speeds as expected throughout my house. I replaced it with the Amplifi system to make my system simpler and supposedly reliable.


  • Hi @kenovk - the speeds you are seeing when connected to a mesh wireless point are likely due to the AmpliFi system not having dedicated backhaul radios

    The mesh points can only communicate with one device (either a client or the main router) at a time and has to act as a relay, therefore speeds drop by roughly half for each wireless hop

    For a 76Mbps Internet connection, 42Mbps over a wireless mesh point would be “normal” and actually quite good in my opinion, for an HD system


  • Hi Derek
    Thank you. It is reasuring at least to know this in a way. That is I think your point on "dedicated backhaul radios" is explaining it as my previous gear was tr-band. When placing the Amplifi points I made sure I do not have hops in the system, each point is connecting directly to the router. So I guess that means adding two additional mesh points won't solve my problem, which is a shame.
    I am not sure I am allowed to post links but this seems very informative on the theory behind home mesh systems like the Amplifi https://www.smallnetbuilder.com/wireless/wireless-features/33023-don-t-get-caught-in-the-wireless-mesh
    That link refers to an Orbi Router and Satellite system and I really wonder if I made the wrong choice getting the Amplfi instead of the Orbi and its satelites? What do you think


Log in to reply