AmpliFi Alien Firmware v3.5.0

  • Is it just me or was 3.4.1 the last firmware where everything including WiFi calling just worked. I have had to turn off WiFi calling on 3.4.3 and 3.5 my MacBook constantly disconnects, especially when not connected to a power source. I have the main until firmware and just requested the mesh unit file to downgrade back.

  • @thernus So.. there were some minor improvements between RC8 and stable. In my opinion you DON'T change anything between last RC and stable, only remove the RC tag 😉 , but I think we are on the same track here.

    Also I am a little allergic to the 'minor improvements' summary. I think they should open up and really involve the beta testers in the changes they made. Now it is still guessing what they are doing.

    I think enough reports show that they fucked up a public/stable release again and that is not what I expected of Ubiquity/AmpliFi when I bought this expensive systems. Fail!

  • @Auke-Wesselink I don't think it is nearly as bad as a fail. Yes there are issues but I imagine they are ones that can be fixed. Also it seems like a relatively small number of users are having issues. Lets give support time to work on the issues and see where we end up.
    I had the disconnection issue on one of the first RC and I have not had it since.

  • RC8 to 3.50 Stable on release day. Download was very fast to Alien router and mesh (ethernet backhaul). Did power cycle all Alien devices to properly apply update.

    In general stability increased with RC6 but sacrificing speed and signal strength carried through into stable version, (range was 40-50% greater in the 3.4.3 version since I have what all call a "cliff" around 35% signal strength). I do use the auto mode and don't separate the bands.

    WiFi 6 known issues persist. Not achieving speeds above WiFi 5 devices and sometimes stubbornly connecting to 2.4Ghz for no reason, (turning WiFi on and/off resolves with reconnecting to 5Ghz).

    Otherwise, I've gone one week with no issues or known drops across iOS, Android, Windows and IoT devices connected to the Aliens, (about 46-50).

    1G Fios wired is rock steady 950/900 up/down. Within inches of Alien router or mesh I've never achieved anything over 450/650 on WiFi 5 or WiFi 6 devices.

    3.50 is making solid progress, but room for improvement at this price point. Definitely, a big improvement over my former HD router with 4 mesh points.

  • @Auke-Wesselink

    Yeah I agree, I would expect no changes from a final RC to Release as well.

    On another note the drop off happened a few times last night again.
    Rebooting the routers fixes the issue for a short period but for now I have just disabled the 5Ghz-AC radio and made a second SSID off the 5Ghz-AX radio for my all my devices. (which is not really ideal)

    Support initially asked me if I go back to 3.4.3 to supply the support file to show the differences in my environment vs 3.5.0 but now I can see they have found what they believe is the issue on the 5Ghz-AC radio/SSID's and have indicated to me there will be a patch soon.
    I have also asked if this will be a beta release or not.

  • Still experiencing the same issue with the second 5GHz radio as in all the recent 3.5.0 RC's. I'm using ethernet backhaul and one by one over days every device I have on the second 5GHz band drops and report they cannot authenticate. I've been either moving them to the 2.4GHz band for devices like Echo, Google Hub, HP OfficeJet and the main 5GHz radio for faster devices like Macbooks. There is nothing I can do to get devices to re-authenticate once they drop, other than reboot the Aliens. Once the devices are connected to either other network, none ever repeat this behavior. I do not understand what is up with the second 5GHz radio. I'm using different ssid's for all three radios but they all have the same password.

    I know ranting isn't productive but this is easily the most frustrating bug I have ever encountered with any brand of wireless router. Tri-band was a big selling point for me when I was researching a replacement for my Asus RT-AC5300 that died recently (which also had 3 radios) and as of now only two are usable on the Alien.

  • No issues to report on v3.5.0 at the two locations I Teleport between (Alien on one side is in Bridge mode)

    No drop-offs, no connection issues, additional 802.11ac 5GHz radio (heavily utilized) is functioning fine...everything seems exactly the same as RC for these configurations, but the hardware is also from the original launch

    Hi @UI-AmpliFi or @UI-Karlis - in the past you always openly stated there were no changes in a public release from the final public RC, so is that true with v3.5.0 or not?

    Sounds like some people are hearing a different story

    Seems out of character that after 8 candidates (5 publicly released) you would do a private RC9 over the span of a few days or jump straight to a modified public release

    For Aliens that are now more than a year old and out of warranty it would help to know if the actual public release has been beta tested or not

  • @mdcraig I'm in bridged mode (Alien QOS isn't that great TBH), and I'm having the same connection issues with the 5Ghz-AC radio, also using separate SSIDs. Manually selected channel 36 which I absolutely have no issues with on my other wireless router. Currently just using the Wifi6 radio and it's fairly stable although my neighbor is transmitting a fairly strong signal in the high bands, hence the want to use the low bands. Will have to find time to send Support some logs when time permits.

  • @Pavel-Shirokikh I'm still waiting for mine to update it was stuck like yours........

  • I'm getting random restarts on 3.5 now. Ticket submitted. Ugh. 😞

  • I really would like to roll back to 3.4 if anyone has the firmware and the process to do so.

  • Okay, a week later, here are the issues I’ve found:

    • My HomeKit randomly says „there was a problem with Home“. My Lifx bulbs do not respond on occasion. This is new with 3.4.3->3.5.0, I did not change anything else about the setup. One weird thing is, before, it would happen with the farthest lights at times, never else. Now; it’s random which light it happens with or even the whole home.
    • Once or twice, my devices were kicked off WiFi and came back again fairly soon. This may be the SSID disappearance issue someone else mentioned.
    • My WiFi 6 device randomly gets downgraded to WiFi 5 and/or 2.4 GHz. The band it can recover from on its own, after some moving around; the WiFi version not. I have to switch WiFi version manually by reconnecting. This is in a weak ish area but still after walking around or changing location, sometimes at that same location it will be 2.4 GHz or WiFi 5. This is weird because the connection strength is 66% or higher even at this location with WiFi 6 and 5 GHz.

    As for system status, it’s usually stable at 3-5% processor and 40-41% memory, and ~60 C with no increase as far as I can tell. No reboots.

  • As a communication engineer, all of these could be issues with directional steering of the WiFi Signal (beamforming). It’s possible the router focuses on providing the best coverage but forgets that certain connected devices exist when doing this calculation, perhaps making the zeros of the beam pattern Land on those devices.

    Mathematically, this can be considered a constrained optimisation problem: How do I maximise bandwidth/connection strength given no disconnection of existing devices e.g. minimum 30% signal strength to all connected devices.

    Another thing could be just random reconnects, and band steering has nothing to do here. This could be the case because this happens even in the same room.

  • @Dan-Nguyen-0 I'm also running in bridge mode, with an EdgeRouter 12. I'm using channel 36 manually selected as well. My Alien would typically select 36 in auto anyway but sometimes used 40 which lowered throughput. I'm using 40MHz bandwidth since none of the devices I originally intended to run on the second 5GHz radio supported more than 2 streams. None of this seems to make any difference with the authentication issue, no matter what options are selected, most if not all devices will eventually drop and complain about the wifi password being incorrect.

  • @mdcraig have you tried changing the password almost sounds like someone is trying to de authentic the WiFi a friend of mine was telling me about how such an attack works.

  • @mdcraig I have the same issue with the wifi password being incorrect for one of my Lenevo laptop on the Wifi 5 radio.

    Tier 3 support said this firmware has a bug with band steering where it will try to steer to the wifi 6 radio even if the network names are different (how I don't know). Their solution until a fix is out is to disable the additional Wifi 5 radio.

  • Hi @Dhananjay-Suresh - is manually installing RC8 a possible temporary fix?

    Does this affect all clients on the 802.11ac radio or just some of them?

    I'm curious since I am not experiencing this issue at either site (one Alien in Bridge mode, one in PPPoE mode) with the Common SSID disabled, a unique 3rd 802.11ac SSID, and Band Steering + Router Steering both disabled

  • @Derek-Saville I am not sure if rolling back to RC8 will fix it because I had the issue on RC8 as well. I believe I had the issue as early as RC6. I am also not sure if it’s the same issue as others experience. I only have one unit. No meshing. I also have band steering and the other one disabled. I never had them enabled.

    My 802.11ac radio is only reserved for a few devices (5-6) compared to the 20+ devices on 802.11ax and only that one Lenovo laptop is experiencing this issue.

  • Thanks @Dhananjay-Suresh - sounds like we have similar setups, but I don’t have any misbehaving 802.11ac clients

    I actually found RC4 to be the most preferred candidate and left a few Aliens on that release until all is finally sorted

  • v3.5.1 has been released:

    With the release notes including Resolved issue with Wi-Fi 6 client steering.

Log in to reply