AmpliFi Alien Firmware v3.5.0


  • When I tried RC6 and RC8, I had devices dropping off the 5Ghz-AC SSID I have setup and refusing to reconnect (I am using 5Ghz-AX as a backhaul exclusively) l logged the bug with RC8 and got a response after the full release of 3.5.0

    I think I will stay on 3.4.3 and give 3.5.0 a miss for now.
    I am also trying to get a copy of 3.4.3 firmware and a manual flash method has anyone been successful with this?
    (I find it very strange there isn't a manual flash method openly available!)

    On a side note if another Beta/RC firmware comes out and I want to rollback will the rollback go to 3.4.3 (what I am on) or 3.5.0 (latest release)?


  • This post is deleted!

  • @Peter-Bunyan Thanks. Still, have tried but in vain. I think I will need a standalone firmware file to update...


  • @ileonhsiao eugh, fustrating to hear that didn't work. Yeah not sure what other options are at your availability now except from manually updating from file or requesting a replacement.


  • @Dhananjay-Suresh
    checked the firmware settings last night (had not looked before). It's on channel 11 with auto still set. Wireless Scan (via MBP) says best channel is 6 but will toss out 11 from time to time as well. I have 38 devices currently connected to a router and a node via ethernet backhaul. For the 2-3 weeks preceding the firmware, my only issue was wifi-cell having trouble reconnecting when roaming between the nodes. Device connections were rock solid with strong upload/download. Immediately after the firmware update, my MBP could not maintain a connection for more than 2 minutes. A hard power cycle for the network made that more stable but I still get dropped connections about once an hour or so. The good news is that they are intermittent and immediately reconnect whereas before they would only reconnect if I forced it to. The iPad has been losing connections 2-3x a day, while not horrible, it wasn't this way before. My NUC and Pi lose connection but immediately regain making it hardly noticeable. Speed to the iPad seems degraded based on streaming videos but, that's too subjective and there are too many other variables there.

    all in all, while connection stability has worsened, it is not at an unusable state.


  • @gr8hifi I only have a single Alien so I can't really share any similar experiences.

    However I do recommend using iStumbler and or some wifi analyzer tool to see in detail what other wifi networks are in your area and if any are conflicting. Not sure when you have 2+ units if they use different channels. If so it is quite possible that one of the nodes is using a channel that is conflicting with some neighbor's wifi just because its the next best one to use.

    Also might be worth while to see if the issues still happen with a single Alien rather than Mesh.


  • So. For the first time I also had complaining partner if I changed the WiFi password... Her iPad Pro couldn't connect anymore out of the blue. Never seen before in the RCs. I really think some QA is malfunctioning here. Sometimes a public is way different than RC track. Did @UI-AmpliFi already mentioned the differences between RC8 and final? There should be differences though!


  • @gr8hifi I'm having similar issues with more than just apple devices.


  • Is there a way to roll back to the previous Firmware?


  • @Lenny-Rossi I have this issue, but only with my separate 5GHz band. All iPhones in my house will connect to 2.4GHz, but not 5GHz after this latest update.


  • @Lenny-Rossi Yes please!!! This update is driving me insane.


  • @Lenny-Rossi you could upload to a free hosting site like filedropper, wetransfer, or even google drive.


  • @Stephen-O-Connell

    Seems like if you have the firmware file you can navigate to this address or what ever your router IP is on http://192.168.1.1/fwupdate.php and then load the file.

    It is pretty ridiculous amplifi don't just allow you to manually download and flash the firmware.


  • @Auke-Wesselink

    I have been trying to convince support there was an issue when I logged a bug for RC8 for the last week or so and not getting really anywhere.

    They told me the below when I asked if there was any difference between the two:
    Q: I can see 3.5.0 is not RC anymore was there changes from RC8?
    A: There were some minor improvements between RC8 and stable.


  • @thernus Agreed, but unfortunately I don't


  • I just had my first event where I left the WiFi area and then returned and it wouldn’t connect back to the wifi6. I had to manually connect to the WiFi5 network and then back to the WiFi6 to get it to connect. When I first attempted to manually connect to WiFi6 it said, unable to connect. 3.5.0

    Edit: This has occurred with an iPhone 12 Pro and Apple TV4k.


  • @thernus that is true. I am going to post the firmware tonigiht


  • @Peter-Bunyan I would like to update my case situation afterwards. After the contact with the AmpliFi engineer team with my machine's support file, they have found out that there is a hardware issue existed which led to the failure of the firmware update. Hence, the RMA request procedure has been initiating to make the replacement of my router. Thumbs up for the AmpliFi engineer team! I think it is still worthwhile to purchase products from such a company for their rapid response and thorough service.


  • @Lenny-Rossi
    Thanks for uploading!

    Support have just provided a link for me to download as well haha
    (just the main router file as I have two routers in mesh)

    Do you know if the firmware is for all Alien Router model numbers or just the US model?

    The file I got matches your router firmware and would think it covers US and EU router models?

    edit: support have confirmed with me the firmware is for all models (US/EU) except the mesh unit.


  • Well I tried 3.5.0 and within about 2 hours my phone dropped off the 5Ghz-AC wireless network when moving from downstairs to upstairs and now it wont reconnect. (I have router units in bridge/mesh mode on each floor)

    I have rebooted both AR's and the phone came back up, see how long it lasts.


Log in to reply