AmpliFi Alien Firmware v3.5.0

  • @UI-AmpliFi Thanks - I opened a case this morning and have sent the support files.
    FYI, remains consistent - about 1/3 or less upstream versus downstream, both LAN and WAM, regardless of what node the devices are connected to.

    For the record, on a wired connection to the Alien, I even get 948 down, 921 up for internet (external) speeds (I am on 1Gbit fiber); so the issue is directly connected to Wifi...

  • Based on all the comments and issues, I will stick with my v3.4.0 which for me has been rock solid, no issues with WiFi calling, network drops and all the other crap. It would be nice if testing and QA was better on their releases. You shouldn’t have to hold your breath every time an update occurs.

  • @Lenny-Rossi Same here, get the bad password prompt. And iPhones jus won't stay connected to wifi.

  • @Robbie-Foust what is the bad password prompt? Wondering if it’s similar to what I experience on just one windows laptop where it doesn’t want to connect to any of the ssids except guest with no password. Only a reboot fixes it.

    Starting occurring during one of the v3.5.0 RCs.

  • I have the 3.4.3 firmware downloaded. Is there a way to upload to here ? Could save you all some grief.
    I downgraded my firmware and everything worked fine.

  • @Lenny-Rossi

    May I please have this firmware, this update is atrocious, my iphones will not connect to wifi.

  • Hi @chronix10 - have you tried resetting your Network Settings on the iOS devices?

    Not ideal, especially if you have a lot of networks to reattach to again, but there are times it can really improve stability

  • @Derek-Saville

    I did, nothing was resolved, same issue. Only started happening on 3.5

  • To AmpliFi team,

    Could you speed up rolling out this update to the whole world...?
    Until today, I still have not received any notification of the update and I desperately need it 'cause the 3.4.3 version is driving me crazy consisting of so many issues such as WiFi 6 broadcasting failure, random IPv6 malfunction, inconsistent upstream rate, etc.

    And as a matter of fact, you could have the other update method prepared, since the Alien has the built-in firmware upload function, just put the firmware file on the website and let the user download on his own and upload it via the Web UI.

    All I ask for is to have this router served with the very basic function: WiFi 6 connectivity. And this is something this product cannot deliver so far. Having the terrible user experience with it. If this update still cannot fix the basic problem, I am considering to make a switch to the other brand. Tired of debugging...

  • Hi @ileonhsiao - you can bypass the rollout by enabling Receive Beta Firmware Updates in the web UI

    The last Beta RC you will receive is the final Public Release

    You can then uncheck the Beta option and it will revert to the latest identical public release if you want to unsubscribe from the beta program

    Just note that you will need to obtain any previous firmware file to manually roll back, but that doesn't sound like a concern in this case...

  • @Derek-Saville Thanks for the tip. However, my case is I already had the Beta option checked, and I have not received either previous 3.5.0 Beta RC or the current 3.5.0 stable firmware.

  • Hi @ileonhsiao - thanks for that feedback

    So you never received RC8 and if you unenroll from Beta it puts you back on v3.4.3?

    It isn't supposed to work that way unless they halt the rollouts

    Maybe @UI-AmpliFi will comment on why that is happening...

  • I logged a ticket for my RaMP reconnecting issue. Also mentioned @UI-AmpliFi in it because we has already spoken about the same in my RC6/RC8 bugreport.

  • I have router set up with separate channels 1 for 2.4 wifi 6, 1 for 5GHZ wifi 5 and 1 for 5GHZ wifi 6. Since updating to 3.5.0 I am seeing more and more devices connected to the 5GHz wifi 5 channel loose connection with the router. Attempts to reconnect report invalid credentials. Sometimes a reboot of the device will enable a connection to be re-established. I have not yet done a factory reset of the router, because unlike other manufactures one of the things that drew me to this router was its stability.

  • @Dhananjay-Suresh The phone just pops up the box to enter the wifi password, I didn't take a screenshot so I don't have the exact wording. To fix it, I just turn wifi off and back on again (on my phone) and it seems to fix it. I've only seen that happen twice so far, but it seems like it switches from wifi to LTE and back somewhat regularly. Not sure what's going on there.

    edit: i have two aliens meshed via wifi if it matters

  • I have had constant connection issues with my iPhone 7+ which is connected to dedicated 5GHz network. After I leave home and came back only powercycle helping me to connect to that SSID again. The SSID appears and disappears for seconds. Resetting iPhone network settings doesn’t work for me.

  • @ileonhsiao

    Hey. Try this.

    Go to amplifi.lan
    Once here ensure Amplifi Beta Options are ticked. Select this and then use the special command "Restart firmware updates daemon."

    Go back to the app and check for firmware updates, it should pull down.

  • @UI-AmpliFi I bought the Alien right after it launched and have not had any significant issues until installing this update.

    With this update the router restarts itself every couple of days.

    Is this a known issue? How can I help?

  • This firmware has really caused trouble. I've power cycled the network and my apple devices no longer maintain steady connections. What a frustrating turn of events.

  • @gr8hifi I have over a dozen Apple devices on the network including 8 Homepods and I have no issues with this firmware or any of the release candidates. Are you sure there’s no channel interference in your area?

Log in to reply