Alien amplify wireless slow speed.


  • So I'm running CenturyLink fiber internet I'm not using their modem it's plugged directly into my alien amplify router. On my wireless download speeds I'm lucky if I hit 300 on my upload speeds I'm getting almost between 700 and 900 on the upload. When I run a speed test directly from the router itself it's very high . Because it's reading off the lan cable plugged into the amplify from the wall which is about 950 on the upload and 780 on the download. I set the VLAN to 201 like people say to do and put in my pppoe username and password and the router works great it's just weird that my download is so low compared to my uploads. And that's using the normal speed test app that everybody uses. But if I run the speed test from Google or say Samsung internet on my Samsung smartphone which is the newest Wi-Fi six capable phone the speeds are fast I get about 500 to 600 on the download and about 8 or 900 on the upload. Any ideas? Thanks


  • I am seeing the same wonkiness after the most recent firmware "upgrade". If I connect hard to the Amplifi I get the 300Mbps delivered here. Even with hardware NAT I am lucky if I get 100Mbps download and its usually 80-90Mbps. My Samsung G20 barely breaks 110Mbps. My upload speed is spot on or greater. Its the download that is sucking wind.


Log in to reply