AmpliFi Alien Firmware v3.5.1

  • I noticed that I had automatic band switching enabled and since I have ethernet backhaul/backbone enabled, I really didn't need this. I did a few tests and it seems to have improved my wifi performance. Although WIFI 6 is still somewhat upside down with upload being higher than download. 375 down and 665 up. At least it's better than 250 down.

  • It’s depressing that the fw has been out for 2-3 weeks and there is still no beta going with a fix for iPhone users like myself.

  • I assume that most simple way for Amplifi could be to adopt for example UDM firmware for Alien rather than constantly fix absolutely useful and laggy existing versions. Or made a choice which one to use for customer.

  • @Pavel-Shirokikh I got the Apple password incorrect error too – on a UDM after a firmware update, so I wouldn't assume it's not affecting other Ubiquiti products. I had to do a hard reset and connect to it via Ethernet to get functionality back.

  • OMG no way to go on this planet ahahah

  • @Holohive1 Please submit a support case.
    We are collecting as much support files with this issue as possible.

  • @UI-AmpliFi I submitted mine yesterday, tried to do it soon after I got the password prompt on a iphone (not sure if that matters).

  • @UI-AmpliFi I noticed that the “wrong password” problem is only with 5GHz bands , the 2.4Ghz works perfectly with every devices , most of my devices from apple iOS , Apple TV , HomePod , MacBook connect to 5Ghz high band and stay connected , but they have a problem “sometime” getting Authentication from the Alien to connect to it in the 5Ghz additional SSID WiFi 5 band.

    The big problem is with android based Sony 4K smart TV as it does not connect to the 5Ghz bands at all it always ask for a password or just seeking for Authentication with no results , in the mean while it connect to the 2.4Ghz band with no problem at all.

    Also Google chrome cast V3 having hard time connect the 5Ghz bands , when it does it takes hours then it switch to 2.4Ghz as it fails to stay connected or reconnect to the 5Ghz band.

    So the problem is only with 5Ghz bands low & high with some devices especially android devices.

    Hope this can help fixing the issue.

  • @UI-AmpliFi when are we getting 3.5.2 which doesn’t have all these issues, and doesn’t introduce new issues?

  • @manank or better.. 3.6.0 or 4.0.0 with all bugs gone (we can only dream about that 😉 )

  • Ever since this firmware my phone will lose all wifi until i reboot the router or turn off private mac address. Waiting on a new beta update that hopefully fixes this. iphone 12max pro.

  • Strange thing happened where for the past 10 days I haven't had any issues on the Lenovo laptop that had been plagued with disconnects. All I did was plug in an ethernet cable once after the last time the issue occurred. But I haven't used it since.

    Maybe plugging in an ethernet fixed some issue internally? Still monitoring it see if it happens again.

  • Still no beta or update yet?

  • @Tristan-Baptist it is quiet indeed...

  • @UI-AmpliFi Past few days, 100% cpu usage (30 devices connected, 11 of those wired) which results in network down, and unable to connect to the router, have to power cycle to get back online. Third software update and each one seems to give worse performance than the last. Very dissapointed that these updates keep breaking things. Think I'm just about done putting up with this, very disapointed with my experience and performance having paid what I did for this device. Going back to untangle and engenius.
    1_1619373727940_IMG_20210425_123539.jpg 0_1619373727939_IMG_20210425_123531.jpg

  • @Scar3cr0w said in AmpliFi Alien Firmware v3.5.1:

    …100% cpu usage (30 devices connected, 11 of those wired) which results in network down, and unable to connect to the router, have to power cycle to get back online.

    The same thing happened to me 10 days after updating to 3.5.1 (see my post a few weeks ago). Had to pull the power cable to reboot the router to get it going again. I submitted a support ticket but not much they could do by the time they got to it days later.

    So far the CPU peg/router freeze has not happened again, but it did spontaneously reboot three weeks later.

  • This is ridiculous. I’m in an exclusively Apple home and nearly all of my devices can’t connect to the 5GHz band reliably. About 50-60% of the time I’ll get a “incorrect password” or “unable to join network” prompt on my iPhone, iPad Pro, or MacBook Pro. This is especially infuriating as the Mac will join the 5GHz band initially, then get kicked off, and loop around, trying to connect to the 5GHz band until it eventually joins the 2.4 Ghz. And, of course, this happens in the middle of Zoom calls for work.

    Splitting out the 2.4 and 5 GHz bands doesn’t make a difference. I get the same prompt on my Mac saying “connection failed”.

    I’ve noticed this will happen especially upstairs, where the signal is a bit weaker (-51/-92). No issues until 3.5.1. Did they not test this with Apple devices at all?!

    Given all of the issues, how do I downgrade? I can’t find the firmware for 3.5 anywhere.

    I’ve purchased another Alien for upstairs as a temporary solution, but my nearly 10 year old AirPort Extreme was way more reliable.

  • @Hoody007 Unfortunately you'll need to contact their support to get a prior firmware version. No idea why they don't provide an n-1 versions available even if it is just for a short duration in between their updates. I have the same issue, and also waiting for a fix. If you are highly dependent on internet for WFH, I recommend having a backup router.

  • @Dan-Nguyen-0

    Got it. Thanks! I assume I just email them? I have my old Extreme but it was getting a bit overloaded with all of the devices I’ve added, and with all of the bandwidth I’m asking it to handle, especially now during the pandemic. Pretty sad to need a backup router for a nearly $400 piece of network hardware…

    Guess I’ll cancel the other Alien as I don’t need it then.

  • Anybody in contact with support who can provide an update on the issue and ETA on the fix? I need my internet to be stable whilst I WFH so this giant paperweight is sitting in the corner for the time being. Also checked their beta section and I do not see any updates. This version was released on March 22nd...nearly a month ago and no update in sight. I will steer my friends clear from this router and brand.

Log in to reply