iPhone 12 Pro Max keeps dropping

  • I just set up an Amplifi Alien + Mesh node and my iPhone 12 Pro Max keeps dropping the WiFi connection. I see lots of people complaining about this but not many solutions. I have the latest firmware on my Amplifi Alien. I also disabled band steering and disabled private address on my iPhone. It hasn't fixed the issue. My laptops are all fine with no drops. Thanks.

  • This just started happening with me as well. I wonder if something changed in the latest iOS that is now borking this feature.


  • Iโ€™ve had some minor connection issues with my iPhone SE (first generation) ever since getting the Alien, but lately they have gotten worse and even the iPad Pro (first gen) started to drop connection to the WiFi network a few seconds every now and then. Especially when accessing a new domain/service. After the latest firmware update, this seem to happen more frequently and on ALL iOS/iPad OS devices (an iPhone SE second gen on WiFi 6 and an older iPad ...maybe a 4), but not the HomePod or AppleTVs. Most devices are up to date to latest versions, but not likely the old IPad.

  • Yes, iOS devices seem particularly bad, but had a drop on my MacBook Pro this morning and I was sitting 10 feet away from the Amplifi node.

  • I have so far yet to see any other device disconnect from wifi regularly besides the iOS/iPadOS devices. Running 4 Macs, 2 of them M1 with latest Big Sur (Air and mini) on Wifi 6, two older running Catalina and something even older in the basement. 3 of them constantly running twitch in low latency mode (I moderate for a few streamers), so any recurring disconnects would be noticed. On top of that, one of the computers stream music from a Synology NAS connected to the main Alien out to HomePods and AppleTVs in house, so any drops there too would likely be noticed (though they my buffer last a few seconds of disconnection), so while other units may be unstable, it's way worse on iOS/iPad OS. At times (though very rarely in my experience) wifi just reconnects on any unit for any number of reasons, so keep an eye on that MacBook to see if it happens again repeatedly, since it would be interesting to see what the difference in that case is between your Mac and mine ๐Ÿ™‚

    Also have 3 Windows 10 computers that haven't had dropped connections once (besides one rare disconnection caused by a bad wifi driver on one of the machines, but that ends up in a BSOD ๐Ÿ˜‰ ) during online gaming so far.

  • @whaleman I am seeing the same thing, and strangely it seems we have almost the exact same kinds of devices in our house. ๐Ÿ™‚

    I tried one thing that seems to be working. I created an additional SSID on the 5 GHz under the "Router additional SSID" setting. I had my iPhone forget the SSID I was having trouble with and only connect to the additional SSID on the 5 GHz and it seems to be much more stable.

  • Originally I could just switch between the 2.4GHz and 5GHz networks (separate SSIDs) to get stability for a while, or delete all network configs on the phone, but it only lasted a short while. Never tried yet another SSID besides that yet though ๐Ÿ™‚

  • I have a 3 router system. I have had issues with it, but seems to come and go now. I suspect it's in the handoff between router to router or router to network handoff from 5GHz to 2.4GHz.


  • There might be issues there as well, but in my case Iโ€™m not moving around and not switching node according to the web interface.plus Iโ€™m clearly nearer the main node than the extending one most of the case, but also when completely out of range of one of the nodes, the issue is there. I also have 2.4 and 5GHz on separate SSIDs, so thereโ€™s no handover there either. And itโ€™s again, only iOS and iPadOS devices ๐Ÿ˜•

  • This exact disconnect is occurring on all my iOS devices also. Wonder when they will address it.

  • Understand the developers are working on a solution in alpha firmware, so hopefully they will gain enough supporting data to move to beta or new stable release.

    I can say that my iOS devices, (XS, iPad and SE 2nd gen) and android devices are working fine. I was experiencing a daily drop and reconnect with the iOS devices. Not to mention inconsistent WiFi switching for my iOS devices between strongest Alien unit when moving around ... this has resolved and transitions quickly to strongest Alien signal.

    Just today on my XS, I was in yard 120 feet away from mesh unit on 2.4 Ghz. As I approached the Alien mesh it switched to 5 Ghz and once inside house closer to main Alien router it switched seamlessly to it at 5Ghz in less than a minute.

    I'm running in auto with one SSID and no additional 5 Ghz radio enabled. Band steering is on, Router steering is off.
    All advanced options are enabled except the 802.11r since this (r) brought other connectivity problems for me.

  • @jbenja6460 I am glad you have had success, I will check my settings again, but this continues to be problematic for me. If I go upstairs or downstairs, its a 50% disconnection rate.

  • @usna92 did you try my suggested solution with the additional 5GHz SSID?

  • @Joel-Dudley-0 Actually, looking at my wireless settings, it had Additional 5GHz radio checked with the same SSID name. I think that is the default setting, but I just replaced my router due to an RMA for the screen failure issue. I am going to see what performance is like with that setting turned off. If that doesn't work, I will create a separate stable 5GHz channel for phones, but I really want to avoid that if possible.

  • @usna92 Yes, unfortunately the fix requires a separate 5GHz SSID with a different name.

  • Hello! We have prepared a fix for this issue. It is included in the latest Beta version. If you are willing to try Beta release here are the release notes and you can opt-in Beta program from Web user interface. You will find a checkbox for receiving Beta firmware at the bottom.

    After confirmation from Beta users that there are no major issues, we will release a stable version.

  • This post is deleted!

  • Only a few hours in so far, but it does indeed appear that 3.5.2 solves this issue for me (or at least greatly reduces it, since I havenโ€™t been using it that long, absolute statements are definitely too early to call ๐Ÿ˜‰ )

  • @whaleman Please keep us updated. Thanks!

  • I think I sorted it before the update, but it had to do with the separate 5GHz network. When I replaced my main station after an RMA, I suspect the default setup was an additional 5GHz network. That network had the same SSID as my "main" network. I suspect the handoff was boinked when switching from station to station, supposedly to the "same" network, but were really two networks with the same name. I killed off the second network and have not seen a reoccurrence since. I just updated the network with the new firmware today, so hopefully that covers any other lingering issues. I have my display back and my phone stays connected, so pretty happy overall right now.


Log in to reply