Alien guest SSID connection


  • Alien firmware 3.5.2, single unit, no mesh.
    IPhone XR, 14.5.1

    I’m having an occasional issue when I try to switch from my primary SSID to the guest SSID on my iPhone. I get the message, Cannot join network. I have tried to forget the network and reconnect, only to have the password rejected.

    I do not seem to have issues with devices that are maintaining a connection to the guest SSID.


  • Hi @McDuff627 - does it matter if you have Private Address enabled or disabled for either or both SSID's?


  • Neither SSID's are flagged as private.


  • Further information on problems connecting to the guest network. I have had issues with various equipment connecting to the guest network - 2 laptops and a laser printer. One of the laptops that failed to connect was my work laptop, which is locked down by my company, but the other laptop showed the same "cannot connect to network" message. I updated the Intel WiFi drivers to the latest release, and then was able to connect. Of course the laser printer does not have wifi drivers availability, but I have updated to the latest firmware for the printer, and it still doesn't connect. All of these were able to connect to my previous router's guest network without a hitch.


Log in to reply