Ability to turn off DHCP server.


  • Ability to turn off DHCP server.
    Possibility to set up own DNS for internal devices.
    Alexa skills app, similar to TP link.


  • +1 on this one!


  • Yes please! +1
    And the ability to configure which DNS servers the DHCP server hands out.


  • +1, I just ran into this issue while deploying my vCenter LAB and ended up having to use the 1 DHCP range trick to get it working.

    There should be the ability to set NetBIOS, Domain, and DHCP Server On/Off/Relay


  • @UBNT-Gunars
    Is it any plans for more dhcp control? Like turn it off completely or set a custom DNS. This is the only important feature missing for me now. I use Pi-Hole ad blocker/custom dns.


  • Pretty much related to this, which is not really getting a conclusive answer....
    https://community.amplifi.com/topic/489/amplifi-dns-server-strips-rfc1918-results-in-replies-to-clients/


  • +1 on this one!


  • Bumping up this one: we should be able to have more control over an internal network layout without loosing the routing features this device provides.

    Layer the levels for configuration: filter for basic, advanced and expert settings as to not overwhelm the user.


  • @kim-nilsson This is number 1 missing feature on my wish list! Just bought a CUJO firewall device that needs the ability to turn off DHCP. The only other alternative for is to turn on Bridge Mode and lose many great features. Not great!


  • My +1 as otherwise happy AmplifiHD user.


  • Hi @UBNT-Brett - does the limited DHCP range hack that other people have reported work to effectively turn off DHCP?

    I have read many times that setting the DHCP range to one available address and then creating a static IP reservation for that one address using a bogus MAC address is the equivalent of 'turning off the AmpliFi DHCP server' - is that true?

    Then all devices will obtain a DHCP reservation from an alternative DHCP server on the LAN?

    Is there any downside to doing this if it works?

    Taking it one step further, if your goal is having Guest WiFi access is pseudo-bridge mode, you can:

    1. put the AmpliFi router in Static IP mode assigning it a fixed IP address compatible with your main upstream WAN router setup

    2. do the DHCP range hack to effectively turn of DHCP

    3. install the Ethernet cable from the upstream WAN router to the AmpliFi LAN and then install a second Ethernet cable from the AmpliFi LAN to the AmpliFi WAN (or use two Ethernet cables from the upstream WAN router to the AmpliFi router, one to the WAN port and one to a LAN port)

    Does that actually work?
    And Guest access will still be segregated even though the AmpliFi DHCP server is effectively turned off?
    And there are no Double NAT issues?

    If these hacks work, then why not do them in firmware?


  • @derek-saville I took a few month break from the maddening limitations of the Amplifi system thinking for sure things would be better by the time I got back, and they are not. It is absolutely insane that the option to turn off DHCP still isn't an option.

    Not only that, but using the DHCP Range Hack effectively bricks my system. I decided to try and get past my prior hang ups and try this system again, resetting all of my equipment and setting it back up. As soon as I set the DHCP Range Hack, boom, the Amplifi cube cannot get to the internet, the Amplifi app cannot connect to it, and I have to reset it all again.

    Looks like my break might become a permanent one. Come Amplifi, get your act together.


  • Hi @jayson-knight - thanks for the feedback.
    Sorry to hear about your continued troubles.

    I am planning to install a USG as my main router and was interested in getting the HD Router to work in 'other-than-Bridge' mode.

    If you don't mind my asking, I assume you are using two Ethernet cables, one from the ISP router to the HD LAN, and then another from the HD LAN to HD WAN?

    And you are running the HD router in static mode?

    And for the DHCP hack, you have an IP reservation to a non-existent MAC to obtain the one available address from the HD router?

    PS - I did finally discover that my Teleport issues were caused by AmpliFi changing the MAC addresses of the internal LAN & WAN.
    The new WAN MAC address broke my IP reservation and port forwarding rules.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.