Connecting two Amplifi HD kits

  • I came across a second Amplifi HD kit. These are the kits with a router and two "bonded" meshpoints. So I wondered if I could use this to improve my current Amplifi setup. Unfortunately today you can't directly add a kit to an existing Amplifi system - it gives you the "incompatible" message.

    So I configured the second kit as a second Amplifi "system". In the configuration the second router is in bridge mode over a wired connection to the existing router. I also matched the SSIDs and password to the existing system.

    In some quick testing everything seems to be working. Devices can attach to any of the routers or meshpoints using the same SSID and password. Since they share a common wired network everything seems to be able to talk with everything else.

    The obvious downside to this approach is there are two different Amplifi "systems" that I have to switch between to see all my devices and manage them. And I end up with two separate mesh networks - the existing and the new one - and they don't talk with each other wirelessly.

    Beside the management headaches of two Amplifi systems and two separate wireless mesh networks that don't talk wirelessly, are there any other issues I should be aware of with this configuration?

  • Just closing this thread by saying the new beta Amplifi firmware that enables you to remove the hardware pairing fixes all these issues. Really great to be able to everything in one place.

    Kudos to Amplifi for being responsive on this!

  • @johnshew which setting in beta did you change? I'm trying to pair two kit like you but getting the error message.

    Thank you

  • You have to reach out to support and they will send you the beta firmware for both the APs and router that can unpair them.

    BTW, once you've done this, it seems to be important to do apply updates on the mainline firmware and then reset the device. I was having a problem with the guest network that resolved itself after an update.

  • Thank you for the reply

Log in to reply