Gigabit Speeds


  • @ubnt-gunars Nothing upstream.

    Router (Ampifi) is connected directly to cable-modem. It correctly obtains IP address via DCHP from the modem.

    Yes, I have enabled hardware NAT from the web interface (when, oh when, will you allow full admin via the web interface? - but that's another topic).

    However, some improvement today.

    • From my iMac (wired connection to the Amplifi router), I get 805Mbps down, 10Mbps up.
    • From my iMac (wifi connection to the Amplifi router - 5ft away), I get 232Mbps down, 10.1Mbps up.
    • Amplifi iPhone app, I get a measely 59.1Mbps down, 10.4Mbps up.
    • iPhone native speed-test app, I get 363Mbps down, 9.68Mbps down.

  • @tony-boggis The built-in speed test is very inaccurate. We're considering removing it. Any idea why your upload is only 10 Mbps? On my gigabit connection upload is usually a little faster than download.


  • @ubnt-gunars My upload is capped at around 10Mbps, so that's expected.

    Download is 1Gbps. At least, that's what I pay for.


  • This post is deleted!

  • @paul-hrabal I did nothing beyond what you did. I plugged AHD into the fiber modem and turned on Hardware NAT. Zip, zip zoooooom. I would try shutting both completely down and then bringing the fiber modem up first and then power up AHD once the fiber modem is up.


  • @Paul-Hrabal powering up your AmpliFi-HD first and waiting until it prompts you to "Plug in cable" to power up your modem is the recommended procedure and I have seen something as simple as that fix this issue. But in some cases powering up the Modem first is needed as @David-Miller said, so please try both.


  • @ubnt-gunars I am not to sure on what Google requires, it has been awhile since I looked into it. I know there are a few people who have done it.


  • @UBNT-Gunars

    Centurylink user here. I have gigabit fiber running to the house and only seeing around 600 Mbps on the router at it best and averaging around 400 Mbps. I've enabled Hardware NAT to little or no difference.

    Is there anything else to try to get gigabit speeds on the router. I'm on PPPOE and VLAN ID set to 201. I've also tested using the router I purchased with CL and an gettin 950 Mbps on average.


  • @mark-parayno Hi Mark! I have the same situation with CenturyLink. What's the speed if you let their router handle PPPoE and still use AmpliFi?


  • @ubnt-gunars
    Just ran it through the CL router and still getting the same result capping at around 200 Mbps


  • I have the same issue, I am using a PPPoE connection with 1000 Mbit/s. Connected with ethernet cable i get around 750 Mbit/s - with or without Hardware NAT enabled.


  • @popescu-sorin Currently PPPoE is not accelerated by HW NAT. However, 750 is a little bit lower than expected. Other customers are getting up to 820.


  • The hardware NAT feature has just been enabled on my Amplifi HD (UK Version) and it has definitely improved my internet speed (Not that it was slow to start with !) I am now getting 350 MB down which is as 10mb improvement and upload has remained at its capped level of 30mb but is constantly at that speed where as before it would drop quite often. A happy camper here ☺


  • @david-miller sadly, I'm not getting anywhere nears that. Wired at best is 160mbps and wireless 80-120.
    dissapointed at best. I've pushed Amplifi to 6 of my friends and two family members. Doesn't make me look good..


  • @brent-wardle A quick guess. Are you using CAT5e or CAT6 ethernet cables to connect your routers & devices? CAT5 will reach a maximum of about ~120mbps which can bottleneck the speed.

    Your problem probably did not come from this issue.


Log in to reply