AmpliFi Alien Dropping wireless device connections

  • Hello:

    I just bought an Alien router and some devices work great and some don't seem too. I have a couple device on the 2.4ghz that are a ways out and have 50 to 60 percent signal strength and keep dropping connections then come back up then drop again after some time. Not sure why its only the 2.4 ones but they are smart light & smart garage door opener. My questions would be has anyone else seen this and any suggestions you may have would be great. Other question is would you think I need a mesh point?

    Thanks for your help in advance!!

  • @Jeep187... Seeing the exact same thing with one of my Wyze Camera V3 and my Chamberlain Smart Garage hub, that are both using 2.4Ghz. Both devices are in the same general area, and show over 50% signal strength. I am quite baffled by this?

  • I’ve had similar issues, but I’m not convinced it’s because of the Alien router. I have 70+ smart devices on my network at any one time, using both 2.4GHz and 5GHz bands. I’ve struggled with the dreaded ‘No Response’ or ‘Unreachable’ errors for a variety of my devices. After a bunch of research and many, many hours of troubleshooting, there seem to be a few common themes with these errors:

    1. Cameras seem to be affected the most. They tend to drop off more frequently than some other devices. I have a Fingbox on my network which sends a notification whenever something enters or drops off of the network. Those logs corroborate my findings.
    2. Some devices NEVER drop off, mostly switches or lights. And brand seems to matter- the more common names like Nanoleaf and iDevices seem to be more reliable than yeelight and others
    3. Any devices that require a separate hub (usually because they utilize a different wireless standard, like Zigbee) seem to be impacted more. That said, the hubs always seem to be online and reachable
    4. If you use Apple’s HomeKit (like I do), that could be the culprit in many instances. I haven’t completely figured this out yet, but it seems to be a ping issue. For instance, I have an Ecobee thermostat that just refuses to keep a reliable connection through HomeKit. But it’s always reachable through the Ecobee app, so it doesn’t seem to be a WiFi issue. Additionally, as soon as I open the app and ‘wake up’ the thermostat, it reappears within HomeKit. I’ve set up a few automations which require interaction with the thermostat every 2-3 hours, and the ‘No Response’ notifications within HomeKit seem to be much less of an issue with the thermostat.

    I can’t tell exactly what’s going on. I’ve tried a variety of settings within the Alien preferences to no avail. Disclaimer: I’m not an IT or network expert, so I’m not sure which settings may impact my network favorably.

    Any suggestions would be appreciated.

  • I am fairly disappointed in the Alien so far, and have only had it a little over a week now. I have been running Asus routers for years now, and never ever had this issue with 2.4Ghz devices. I'll give it some more time to work itself out, but somebody has got to fix this nonsense.

  • If y'all have enabled DFS on the unit, that may make it worse or better, because it runs on lower signal and can fine tune things once it has run. If you have not, you might try that, and give it 24 hours to stabilize after a power cycle.

    See if you can install the WiFiman at by Ubiquiti and you can see what wireless may be interfering with your signals. 2.4 Legacy really kind of sucks, particularly when you are trying to run it with the newest WiFi6 IMO.

    Finally, some basic setup items, worth taking a look are posted in the release thread. Pay particular attention to the signal between Aliens if you have multiple ones.


  • See if you can install the WiFiman at by Ubiquiti and you can see what wireless may be interfering with your signals.

    Hi @unseenone - not on iOS / iPadOS you will...

    To the best of my knowledge the only iOS / iPadOS app with privileges to ascertain the WiFi environment is still Apple's own AirPort Utility with the Wi-Fi Scanner enabled

  • @Derek-Saville My wife has an iPhone, and we have an iPad, never have had an issue at all with it. I connect the ipad to the WiFi5 AP name though. I have the WiFiMan app on my android.

  • I've only had the Alien for a few hours and am already seeing the router not advertising any SSID. I'm on 3.6.0 firmware. I tried DFS and they seemed to make it worse? So I disabled DFS and back to 'normal'. But even prior to enabling DFS the router was not advertising any SSID. It's hard to say when it happens. It's not right away, but so far I've had to unplug/replug router, just to get connectivity again.

    I am on bridge mode if that makes any difference.

  • @Rolando-Nispiros Hi, please reach out to our support team.

  • @UI-AmpliFi Will do, thank you!

  • I've got this problem real bad. Smart home setup with 50 wifi clients on my home network, Amplifi Alien with basically default settings except some basics: different private ip range/mask & SSID/Password. Have to reboot it every 2 days to get the wifi clients connected again. Fucked up part is that if the Amplifi Alien is in Bridge mode, things are all fine and dandy, except I'm stuck with AT&T's terrible DNS service. Little frustrated with the lack of even the most basic of software options in the Amplifi App / WebUI.

  • I bought another Alien Router to use as a mesh point and that seems to have helped with all but one Wemo outdoor smart plug. Everything else seems to be staying up now. It's weird because I never had to have a mesh system until now. Maybe I should've went with Ubiquiti instead of amplifi but anyway seems to work except for the smart plug that stays on for a while then drops off but ends up coming back for a while then drops again.

  • The beta firmware 3.6.1 seems to have fixed my disconnects. Will keep you updated if that changes.

  • Few days in, the problem is starting back up again... =(

  • I started experiencing this issue recently so I updated the firmware to version 3.6.1 in hopes of a solution. However, I’m still experiencing clients randomly disconnect. My wife and I work from home and don’t experience disconnects on our Windows laptops. Issues is only on Apple devices and Smart TV’s which I’m guessing are running some form of Linux. So my guess right now is that Ubiquiti Alien is having issues particularly with *NIX devices (which means Linux or UNIX).

    Update 10/13/21 - It happens on our Windows devices too but not as often.

    Update 10/19/21 - Updated to firmware 3.6.2. WiFi stability improved dramatically. No longer experiencing crazy disconnects but did notice a degrade in internet performance. Went from averaging around 820 Mbps to mid/high 600's. If it's not one thing it's another.

    Update 10/20/21 - Encountered first WiFi drop on iPhone running iOS 15.0.2. Windows machines show better stability than their Apple counterparts.

  • This post is deleted!

  • hello there, I've just bought an Amplifi Alien router, and set it up on the Friday that's just past.

    My Sonos One speaker and my macMini cannot connect to my AmpliFi Alien router’s wireless? Any suggestions please, I'm using a "Common" SSID for both 2.4GHz and 5GHz.

Log in to reply